View Single Post
Old 07-08-10, 06:00 PM   #10
mocharhw
Registered User
 
Join Date: May 2008
Posts: 113
Default Re: Always Tearing on 8600 GTS

It's hard to tell what I'm seeing in that video. It looks like the mplayer video had some interlacing artifacts in it, but it's hard to tell if there was actual vsync tearing. The desktop window tearing is normal in linux, see many threads about that. It's some limitation of X windows but can be worked around if you use an OpenGL compositing manger like Compiz, but I would get rid of Compiz and just use a normal window manager because it also has its share of video problems. The OpenGL game definitely had vsync tearing in it. Try declaring the environment variables in your ~/.profile or ~/.bashrc files, that's where I do it. Get rid of the TripleBuffer option in your xorg.conf, that causes a ton of OpenGL problems in my experience. Try disabling the composite extension in your xorg.conf and uninstall Compiz, add the following to the bottom:

Code:
Section "Extensions"
        Option  "Composite" "Disable"
EndSection
TwinView should work fine, I use it everyday. Try running glxgears and tell us what it says in the terminal, if you have OpenGL vsync properly turned on then the number of output frames should match your monitor's refresh rate.
mocharhw is offline   Reply With Quote