View Single Post
Old 07-20-10, 01:14 PM   #8
lintweaker
Registered User
 
Join Date: Oct 2004
Posts: 44
Question Re: No audio from HDMI (MCP89 / Geforce 320M): Reason: no connected devices detected

OK, with a patched kernel I got a bit further. With only a TV connected and with TV and receiver both connected they get properly detected.
Unfortunately I can only get distorted sound from my TV and from my receiver. Unplugging and re-inserting of the HDMI cable to not get detected. I guess the workaround can only get me so far.

Output from /proc/asound/card0/eld#5.0 (with both receiver and TV connected):
Code:
[root@macmini2010 card0]# more eld#5.0 
monitor_present		1
eld_valid		1
monitor_name		Panasonic-TV
connection_type		HDMI
eld_version		[0x2] CEA-861D or below
edid_version		[0x3] CEA-861-B, C or D
manufacture_id		0xa934
product_id		0xa0a6
port_id			0x20000
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x5f] FL/FR LFE FC RL/RR RC RLC/RRC
sad_count		8
sad0_coding_type	[0x1] LPCM
sad0_channels		2
sad0_rates		[0x1ee0] 44100 48000 88200 176400 192000 384000
sad0_bits		[0xe0000] 16 20 24
sad1_coding_type	[0x1] LPCM
sad1_channels		8
sad1_rates		[0x1ee0] 44100 48000 88200 176400 192000 384000
sad1_bits		[0xe0000] 16 20 24
sad2_coding_type	[0x2] AC-3
sad2_channels		6
sad2_rates		[0xe0] 44100 48000 88200
sad2_max_bitrate	640000
sad3_coding_type	[0x7] DTS
sad3_channels		7
sad3_rates		[0x6e0] 44100 48000 88200 176400 192000
sad3_max_bitrate	1536000
sad4_coding_type	[0x9] DSD (One Bit Audio)
sad4_channels		6
sad4_rates		[0x40] 48000
sad5_coding_type	[0xa] E-AC-3/DD+ (Dolby Digital Plus)
sad5_channels		8
sad5_rates		[0xc0] 48000 88200
sad6_coding_type	[0xc] MLP (Dolby TrueHD)
sad6_channels		8
sad6_rates		[0x1480] 88200 192000
sad7_coding_type	[0xb] DTS-HD
sad7_channels		8
sad7_rates		[0x1480] 88200 192000
Output from /proc/asound/card0/eld#5.0 (TV connected):
Code:
monitor_present		1
eld_valid		1
monitor_name		Panasonic-TV
connection_type		HDMI
eld_version		[0x2] CEA-861D or below
edid_version		[0x3] CEA-861-B, C or D
manufacture_id		0xa934
product_id		0xa0a6
port_id			0x20000
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x0]
sad_count		1
sad0_coding_type	[0x1] LPCM
sad0_channels		2
sad0_rates		[0xe0] 44100 48000 88200
sad0_bits		[0x20000] 16
Update: 23 July 2010:
Got everything working with the workaround ALSA patch. Both MythTV and mplayer happily play PCM, DTS, AC3 sound through the HDMI port. I noticed on the alsa-devel list there is a proper patch brewing so that's good news.

Last edited by lintweaker; 07-23-10 at 03:12 AM. Reason: added status update
lintweaker is offline   Reply With Quote