View Single Post
Old 07-25-10, 10:52 AM   #1
Nechushtan
Registered User
 
Join Date: Dec 2005
Posts: 21
Default GT220 on Ubuntu Lucid, can't restart X

Interesting issue I'm having.

So I've got a motherboard with an onboard 7050 GPU and a GT220 in the PCI slot. I've got Ubuntu Lucid with all the latest packages.

Upon initial boot everything loads fine, but if I, say either kill Xorg or stop gdm and then try to restart X I can't.

I get the following in my dmesg log:
<code>[ 1717.483473] NVRM: RmInitAdapter failed! (0x12:0x2b:1671)
[ 1717.483482] NVRM: rm_init_adapter(0) failed</code>

and this in the Xorg.0.log:
<code>
(EE) Jul 25 11:45:01 NVIDIA(0): Failed to initialize the NVIDIA graphics device
PCI:2:0:0.
(EE) Jul 25 11:45:01 NVIDIA(0): Please check your system's kernel log for ad
ditional error
(EE) Jul 25 11:45:01 NVIDIA(0): messages and refer to Chapter 8: Common Prob
lems in the
(EE) Jul 25 11:45:01 NVIDIA(0): README for additional information.
(EE) Jul 25 11:45:01 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati
on.

ddxSigGiveUp: Closing log
</code>

everytime X tries to start

I've also tried installing the newer 256.35 via a PPA repo, and the "stock" 195.36 driver from the standard Ubuntu repo.

This is driving me a little crazy so I'm hoping someone here knows what's going on...

thanks!
Nechushtan is offline   Reply With Quote