View Single Post
Old 07-28-10, 10:43 AM   #5
cmessina
Registered User
 
Join Date: Dec 2004
Posts: 7
Default Re: GT220 256.35 Kernel 2.6.34 rminitadapter failed

Quote:
Originally Posted by Ulukai View Post
Try removing nouveau (you don't need it installed if you're going to use the Nvidia blob anyway) and boot in runlevel 3 (no X). You can do it from the command line: enter grub and just edit the kernel line and put "3" behind it. Be sure to load your new kernel (34).

Purge the Nvidia drivers and reinstall them completely. Generate an xorg.conf with nvidia-xconfig and move it from /etc to /etc/X11.

Reboot normally and your login manager should appear, with the loaded Nvidia module.
Ok, uninstalled the nouveau driver package, removed any other nvidia RPM that yast listed, ran the .run package with --uninstall to clear out those drivers. Rebooted. Ran the .run for the 256.35 drivers and installed them. Rebooted.

Same errors with startx and in the kernel log.

Quote:
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:4:0:0.
(EE) NVIDIA(0): Please check your system's kernel log for additional error
(EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) NVIDIA(0): README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Screen(s) found, but none have a usable configuration.
Quote:
[ 19.703248] nvidia 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 19.703364] nvidia 0000:04:00.0: setting latency timer to 64
[ 19.703371] vgaarb: device changed decodes: PCI:0000:04:00.0,olddecodes=io+mem,decodes=nonew ns=io+mem
[ 19.703830] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 256.35 Wed Jun 16 18:42:44 PDT 2010
[ 19.899698] NVRM: RmInitAdapter failed! (0x30:0x49:842)
[ 19.899710] NVRM: rm_init_adapter(0) failed
BTW, while it is in the log quotes above, I wanted to specifically point out that this is all with a 64-bit kernel and drivers.

Last edited by cmessina; 07-28-10 at 10:50 AM. Reason: Wanted to specify the 64-bitness of everything.
cmessina is offline   Reply With Quote