View Single Post
Old 07-28-10, 08:29 PM   #3
ProgrammerTim
Registered User
 
Join Date: Jul 2010
Posts: 3
Unhappy Re: Drivers won't load: EVGA GS250, Ubuntu 10.04(32bit),Asus A8N-SLI, AMD64 X2 4800

Ok, I looked in the readme. Couldn't find a way to search it, so I had to go through page by page. Still almost missed the entry because I was searching the pages for "vmap", which wasn't there.

The readme tells me it is some sort of memory issue, and I can't tell whether it is saying that Linux is allocating all of the memory for itself, or is allocating just a small portion for itself and not enough for the graphics drivers. Regardless, I need to set a kernel parameter.

Google search for "how do I set kernel parameters in ubuntu" came up with this:
https://help.ubuntu.com/7.04/install...oot-parms.html
Wasn't actually helpful, but the link for previous page took me to "Booting the installer in x86".
https://help.ubuntu.com/7.04/install...6/ch05s01.html
I'm using grub, so that at least told me I need to modify my grub menu.
Google search for "where is the grub menu" turned up this page,
http://www.howtoforge.com/working_with_the_grub_menu
which points to /boot/grub/menu.lst or /boot/menu.lst. Neither of those actually exist on my system, but one of the commenters pointed out that their system uses /boot/grub/grub.cfg. That I found.

Back to the error message, it gives me a parameter (vmalloc) and a number (16781312), so I prepared to add this to my my first kernel line. Unfortunately, I couldn't find "kernel" anywhere in the file. I do find what look like my boot entries, and I see a call to initrd that the HowToForge page said was supposed to be there, so I'm guessing that the "linux" line is used in linux instead of the "kernel" line. I have added the parameters to the first one, and commented out the old ones, which I am guessing are the original 9.1 and updated 9.(whatever) kernels. I did leave the "recovery" option, of course.

The comments at the top state that I shouldn't modify the file because it is autogenerated. Is there somewhere else I should make this change so it doesn't get overwritten by some future autogeneration, or is that not something I have to worry about until I upgrade/update again?

Anyway, I rebooted and still received the error. The new log file is attached and the relevant section of the grub menu is listed below in case I screwed something up. I found the error in the old log file and saw that it is present seven times with the same number. It is now present just twice, and both of them have different numbers. The first has 10817536 and the second has 67112960. Does this mean I need the larger of these in the file, or am I missing a point somewhere (I guess it does at least mean that I was right about "linux" being the linux kernel line, hopefully)? FYI, now that it appears related to memory, I have 3 gig of ram installed, if the log file isn't already telling you that. So what vmalloc size should I be using, or is it not calculable and I just have to rely on trial and error?

Relevant grub menu section...
---------------------------------
menuentry 'Ubuntu, with Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 4107a0c9-bc2f-43c7-8be0-3877f9a42d2d
linux /boot/vmlinuz-2.6.32-24-generic root=UUID=4107a0c9-bc2f-43c7-8be0-3877f9a42d2d ro quiet splash vmalloc=16781312
initrd /boot/initrd.img-2.6.32-24-generic
}
---------------------------------
Attached Files
File Type: gz nvidia-bug-report.log.gz (58.4 KB, 46 views)
ProgrammerTim is offline   Reply With Quote