View Single Post
Old 07-31-10, 12:46 AM   #1
Robertux
Registered User
 
Robertux's Avatar
 
Join Date: Jul 2010
Location: Salta, Argentina
Posts: 5
Send a message via MSN to Robertux
Default Resume from hibernation fail with 96.43.16 driver.

Hello, I have the problem that when upgrading Xorg of the version 7.4 to 7.5 in Slitaz 3, the controller NVIDIA-Linux-x86-96.43.18 ( and the 96.43.16 too), doesn't return of the hibernation.
If I change the controller Nvidia for the generic vesa driver in xorg.conf, the system resume without problems from the hibernation.

These are the /var/log/messages of when it returns successfully and when he fails in making it::

Jul 31 00:57:33 (none) user.info kernel: PM: Syncing filesystems ...
Jul 31 00:58:13 (none) daemon.notice acpid: client 4468[0:0] has disconnected
Jul 31 00:58:13 (none) daemon.notice acpid: client connected from 4468[0:0]
Jul 31 00:58:13 (none) daemon.info acpid: 1 client rule loaded
Jul 31 00:58:13 (none) user.info kernel: done.
Jul 31 00:58:14 (none) user.warn kernel: Freezing user space processes ... (elapsed 0.01 seconds) done.
Jul 31 00:58:14 (none) user.warn kernel: Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Jul 31 00:58:14 (none) user.info kernel: PM: Preallocating image memory... done (allocated 65712 pages)
Jul 31 00:58:14 (none) user.info kernel: PM: Allocated 262848 kbytes in 0.67 seconds (392.31 MB/s)
Jul 31 00:58:14 (none) user.warn kernel: Suspending console(s) (use no_console_suspend to debug)
Jul 31 00:58:14 (none) user.info kernel: mpu401 00:0c: disabled
Jul 31 00:58:14 (none) user.debug kernel: ACPI handle has no context!
Jul 31 00:58:14 (none) user.info kernel: parport_pc 00:08: disabled
Jul 31 00:58:14 (none) user.info kernel: serial 00:07: disabled
Jul 31 00:58:14 (none) user.debug kernel: ACPI handle has no context!
Jul 31 00:58:14 (none) user.info kernel: VIA 82xx Audio 0000:00:11.5: PCI INT C disabled
Jul 31 00:58:14 (none) user.debug kernel: ACPI handle has no context!
Jul 31 00:58:14 (none) user.info kernel: VIA_IDE 0000:00:11.1: PCI INT A disabled
Jul 31 00:58:14 (none) user.info kernel: agpgart-via 0000:00:00.0: Refused to change power state, currently in D0
Jul 31 00:58:14 (none) user.info kernel: PM: freeze of devices complete after 802.946 msecs
Jul 31 00:58:14 (none) user.info kernel: PM: late freeze of devices complete after 0.295 msecs
Jul 31 00:58:14 (none) user.info kernel: ACPI: Preparing to enter system sleep state S4
Jul 31 00:58:14 (none) user.info kernel: PM: Saving platform NVS memory
Jul 31 00:58:14 (none) user.info kernel: PM: Creating hibernation image:
Jul 31 00:58:14 (none) user.info kernel: PM: Need to copy 63758 pages
Jul 31 00:58:14 (none) user.info kernel: PM: Restoring platform NVS memory
Jul 31 00:58:14 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKA] BIOS reported IRQ 0, using IRQ 20
Jul 31 00:58:14 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKB] BIOS reported IRQ 0, using IRQ 21
Jul 31 00:58:14 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKC] BIOS reported IRQ 0, using IRQ 22
Jul 31 00:58:14 (none) user.info kernel: ACPI: Waking up from system sleep state S4
Jul 31 00:58:14 (none) user.debug kernel: ndiswrapper 0000:00:0a.0: restoring config space at offset 0x1 (was 0x2900007, writing 0x2900107)
Jul 31 00:58:14 (none) user.debug kernel: VIA_IDE 0000:00:11.1: restoring config space at offset 0x1 (was 0x2900003, writing 0x2900007)
Jul 31 00:58:14 (none) user.info kernel: PM: early restore of devices complete after 0.432 msecs
Jul 31 00:58:14 (none) user.debug kernel: pci 0000:00:01.0: setting latency timer to 64
Jul 31 00:58:14 (none) user.warn kernel: usb usb2: root hub lost power or was reset
Jul 31 00:58:14 (none) user.warn kernel: usb usb3: root hub lost power or was reset
Jul 31 00:58:14 (none) user.warn kernel: usb usb4: root hub lost power or was reset
Jul 31 00:58:14 (none) user.warn kernel: usb usb1: root hub lost power or was reset
Jul 31 00:58:14 (none) user.info kernel: VIA_IDE 0000:00:11.1: PCI INT A -> Link[ALKA] -> GSI 20 (level, low) -> IRQ 20
Jul 31 00:58:14 (none) user.info kernel: VIA 82xx Audio 0000:00:11.5: PCI INT C -> Link[ALKC] -> GSI 22 (level, low) -> IRQ 22
Jul 31 00:58:14 (none) user.debug kernel: VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
Jul 31 00:58:14 (none) user.info kernel: serial 00:07: activated
Jul 31 00:58:14 (none) user.info kernel: parport_pc 00:08: activated
Jul 31 00:58:14 (none) user.info kernel: mpu401 00:0c: activated
Jul 31 00:58:14 (none) user.debug kernel: hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
Jul 31 00:58:14 (none) user.info kernel: hda: UDMA/100 mode selected
Jul 31 00:58:14 (none) user.debug kernel: hdd: host max PIO5 wanted PIO255(auto-tune) selected PIO4
Jul 31 00:58:14 (none) user.info kernel: hdd: UDMA/33 mode selected
Jul 31 00:58:14 (none) user.info kernel: PM: restore of devices complete after 236.404 msecs
Jul 31 00:58:14 (none) user.warn kernel: Restarting tasks ... done.

And when not resume at at all:

Jul 31 01:04:17 (none) user.info kernel: PM: Syncing filesystems ...
Jul 31 01:04:58 (none) user.info kernel: done.
Jul 31 01:04:58 (none) user.warn kernel: Freezing user space processes ... (elapsed 0.01 seconds) done.
Jul 31 01:04:58 (none) user.warn kernel: Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Jul 31 01:04:58 (none) user.info kernel: PM: Preallocating image memory... done (allocated 65712 pages)
Jul 31 01:04:58 (none) user.info kernel: PM: Allocated 262848 kbytes in 1.03 seconds (255.19 MB/s)
Jul 31 01:04:58 (none) user.warn kernel: Suspending console(s) (use no_console_suspend to debug)
Jul 31 01:04:58 (none) user.info kernel: mpu401 00:0c: disabled
Jul 31 01:04:58 (none) user.debug kernel: ACPI handle has no context!
Jul 31 01:04:58 (none) user.info kernel: parport_pc 00:08: disabled
Jul 31 01:04:58 (none) user.info kernel: serial 00:07: disabled
Jul 31 01:04:58 (none) user.debug kernel: ACPI handle has no context!
Jul 31 01:04:58 (none) user.info kernel: VIA 82xx Audio 0000:00:11.5: PCI INT C disabled
Jul 31 01:04:58 (none) user.debug kernel: ACPI handle has no context!
Jul 31 01:04:58 (none) user.info kernel: VIA_IDE 0000:00:11.1: PCI INT A disabled
Jul 31 01:04:58 (none) user.info kernel: PM: freeze of devices complete after 525.313 msecs
Jul 31 01:04:58 (none) user.info kernel: PM: late freeze of devices complete after 0.326 msecs
Jul 31 01:04:58 (none) user.info kernel: ACPI: Preparing to enter system sleep state S4
Jul 31 01:04:58 (none) user.info kernel: PM: Saving platform NVS memory
Jul 31 01:04:58 (none) user.info kernel: PM: Creating hibernation image:
Jul 31 01:04:58 (none) user.info kernel: PM: Need to copy 63783 pages
Jul 31 01:04:58 (none) user.info kernel: PM: Restoring platform NVS memory
Jul 31 01:04:58 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKA] BIOS reported IRQ 0, using IRQ 20
Jul 31 01:04:58 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKB] BIOS reported IRQ 0, using IRQ 21
Jul 31 01:04:58 (none) user.warn kernel: ACPI: PCI Interrupt Link [ALKC] BIOS reported IRQ 0, using IRQ 22
Jul 31 01:04:58 (none) user.info kernel: ACPI: Waking up from system sleep state S4
Jul 31 01:04:58 (none) user.debug kernel: agpgart-via 0000:00:00.0: restoring config space at offset 0x1 (was 0x22300006, writing 0xa2300006)
Jul 31 01:04:58 (none) user.debug kernel: ndiswrapper 0000:00:0a.0: restoring config space at offset 0x1 (was 0x2900007, writing 0x2900107)
Jul 31 01:04:58 (none) user.debug kernel: VIA_IDE 0000:00:11.1: restoring config space at offset 0x1 (was 0x2900003, writing 0x2900007)
Jul 31 01:04:58 (none) user.debug kernel: nvidia 0000:01:00.0: restoring config space at offset 0x3 (was 0x2000, writing 0xf800)
Jul 31 01:04:58 (none) user.info kernel: PM: early restore of devices complete after 0.450 msecs
Jul 31 01:04:58 (none) user.debug kernel: pci 0000:00:01.0: setting latency timer to 64
Jul 31 01:04:58 (none) user.warn kernel: usb usb2: root hub lost power or was reset
Jul 31 01:04:58 (none) user.warn kernel: usb usb3: root hub lost power or was reset
Jul 31 01:04:58 (none) user.warn kernel: usb usb4: root hub lost power or was reset
Jul 31 01:04:58 (none) user.warn kernel: usb usb1: root hub lost power or was reset
Jul 31 01:04:58 (none) user.info kernel: VIA_IDE 0000:00:11.1: PCI INT A -> Link[ALKA] -> GSI 20 (level, low) -> IRQ 20
Jul 31 01:04:58 (none) user.info kernel: VIA 82xx Audio 0000:00:11.5: PCI INT C -> Link[ALKC] -> GSI 22 (level, low) -> IRQ 22
Jul 31 01:04:58 (none) user.debug kernel: VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
Jul 31 01:04:58 (none) user.info kernel: serial 00:07: activated
Jul 31 01:04:58 (none) user.info kernel: parport_pc 00:08: activated
Jul 31 01:04:58 (none) user.info kernel: mpu401 00:0c: activated
Jul 31 01:04:58 (none) user.debug kernel: hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
Jul 31 01:04:58 (none) user.info kernel: hda: UDMA/100 mode selected
Jul 31 01:04:58 (none) user.debug kernel: hdd: host max PIO5 wanted PIO255(auto-tune) selected PIO4
Jul 31 01:04:58 (none) user.info kernel: hdd: UDMA/33 mode selected
Jul 31 01:04:58 (none) user.info kernel: PM: restore of devices complete after 239.820 msecs
Jul 31 01:04:58 (none) user.warn kernel: Restarting tasks ... done.
Jul 31 01:04:59 (none) daemon.notice acpid: client 4807[0:0] has disconnected
Jul 31 01:04:59 (none) daemon.notice acpid: client connected from 4807[0:0]
Jul 31 01:04:59 (none) daemon.info acpid: 1 client rule loaded
Jul 31 01:05:08 (none) user.err kernel: NVRM: Xid (0001:00): 16, Head 00000001 Count 00002b95
Jul 31 01:05:13 (none) user.err kernel: NVRM: Xid (0001:00): 8, Channel 0000001f
Jul 31 01:05:20 (none) user.err kernel: NVRM: Xid (0001:00): 16, Head 00000001 Count 00002b96
Jul 31 01:05:25 (none) user.err kernel: NVRM: Xid (0001:00): 8, Channel 0000001f
Jul 31 01:05:32 (none) user.err kernel: NVRM: Xid (0001:00): 16, Head 00000001 Count 00002b97
Jul 31 01:05:37 (none) user.err kernel: NVRM: Xid (0001:00): 8, Channel 0000001f

For that seen, the part but developing of what impedes the correct return of the hibernation it is in the last six lines...

Does this problem, have some solution? From already thank you...!

PD: The hardware in question is: GeForce4 MX 4000 Dual Head.

Last edited by Robertux; 07-31-10 at 12:48 AM. Reason: corrections
Robertux is offline   Reply With Quote