View Single Post
Old 08-05-10, 07:14 PM   #22
mick232
Registered User
 
Join Date: Oct 2008
Posts: 21
Default Re: Poor 2D Performance

Something to try in case you are suffering sub-par 2D performance:

Set the PixmapCacheRoundSizeKB to a higher value

nvidia-settings -a PixmapCacheRoundSizeKB=16000

My system is more responsive now. And the sluggishness after using the system after a while is gone.

It seems the default value of 1024 is a bad choice for my GF 8200 (with onboard video memory).

I also have a cron-job in place that flushes the pixmap cache every 20 minutes (by turningit off and on again):

nvidia-settings -a PixmapCache=0
nvidia-settings -a PixmapCache=1

It seems the cache got fragmented or thrashed after a while which might have caused the sluggishness.

---

gtkperf (100 rounds) score is now down to 2.98 which is quite good:

GtkPerf 0.40 - Starting testing: Fri Aug 6 02:29:42 2010

GtkEntry - time: 0,02
GtkComboBox - time: 0,57
GtkComboBoxEntry - time: 0,44
GtkSpinButton - time: 0,03
GtkProgressBar - time: 0,01
GtkToggleButton - time: 0,04
GtkCheckButton - time: 0,03
GtkRadioButton - time: 0,06
GtkTextView - Add text - time: 0,47
GtkTextView - Scroll - time: 0,07
GtkDrawingArea - Lines - time: 0,38
GtkDrawingArea - Circles - time: 0,50
GtkDrawingArea - Text - time: 0,26
GtkDrawingArea - Pixbufs - time: 0,08
---
Total time: 2,98
mick232 is offline   Reply With Quote