View Single Post
Old 08-09-10, 03:27 PM   #28
gisl
Registered User
 
Join Date: Jul 2010
Posts: 6
Default Re: Poor 2D Performance

I was also experiencing a very sluggish desktop (using KDE and some GTK apps). gtkperf reported some very slow 12.5s for 100 test rounds of everything.

Quote:
Originally Posted by gradinaruvasile View Post
Does your GPU have dynamic clock setings (multiple performance levels)? Check in nvidia-settings -> PowerMizer.
Taking a look there I noticed that nvidia-settings reported GPUPowerSource = 1 (Battery) even though I was on AC. The PowerMizer mode was set to "Adaptive". So I unplugged that cable, plugged it in again. nvidia-settings still showed to be on battery. I restarted nvidia-settings, and then 2d performance was suddenly great again! The tool still reports to be on battery, though.

I'm not sure what it was that did the trick (un- and re-plugging in the cable or restarting nvidia-settings, or both), but I'm happy that the system is usable again. gtkperf reports some reasonable 2.5s now.

EDIT: I'm not using the 256 driver yet, but 195.36.
gisl is offline   Reply With Quote