View Single Post
Old 08-13-10, 11:32 AM   #73
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Enable audio through HDMI on GT240

zim2dive,

First, you should try removing the options "enable_msi=0" and/or "probe_mask=0xffff,0xfff2" from /etc/modprobe.d/sound.conf and rebooting. The first option should now be the in-kernel default for any NVIDIA audio controller as I understand it. I believe the second option restricts the set of codecs that the driver searches for, and could possibly be knocking out your analog port on the motherboard audio controller. Note that removing this option might change the card/device/... IDs of any existing working ports.

What does "sudo aplay -L" say? What is the content of /proc/asound/cards?

Thanks.
Stephen Warren is offline   Reply With Quote