View Single Post
Old 08-16-10, 04:37 AM   #1
euromonkey
Registered User
 
Join Date: Aug 2010
Posts: 5
Default PowerMizer settings in xconf.org not taking effect (Quadro FX 2700M, v256.35)

Hi all,

I have a Dell M6400 with a Quadro FX 2700M running openSUSE 11.2 and v256.35 of the NVIDIA drivers.

I want to reduce the performance level to save power and reduce heat.

Current settings:
nvidia-settings -q GPUPerfModes -t
perf=0, nvclock=169, memclock=100 ; perf=1, nvclock=275, memclock=300 ; perf=2, nvclock=400, memclock=300 ; perf=3, nvclock=530, memclock=799

nvidia-settings -q GPUCurrentPerfLevel -t
3
nvidia-settings -q GPUCurrentClockFreqs -t
530,799

I tried adding the following line in the "Device" section of my xorg.conf and rebooted but it had no effect:

Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"

That was with v195.x.x of the driver. I then installed v256.35 and reran nvidia-xconfig which produced the xorg.conf shown at the end. nvidia-xconf moved my lines to the "Screen" section but after a reboot, the performance levels were the same.

How can I get this to work?

Many thanks!

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 256.35 (buildmeister@builder97.nvidia.com) Wed Jun 16 19:15:05 PDT 2010

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder58) Fri Mar 12 02:13:46 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "IQT HDIT22W DSUB"
HorizSync 31.0 - 82.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 2700M"
EndSection

Section "Screen"

# Removed Option "TwinViewXineramaInfoOrder" "CRT-0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: 1920x1080 +0+0, DFP-0: nvidia-auto-select +1920+0, DFP-1: NULL"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-1"
Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
Option "UseEdidDpi" "FALSE"
Option "DPI" "96 x 96"
SubSection "Display"
Depth 24
EndSubSection
EndSection
euromonkey is offline   Reply With Quote