View Single Post
Old 08-24-10, 08:01 PM   #1
uOpt
FreeBSD cheering section
 
uOpt's Avatar
 
Join Date: Nov 2004
Location: Boston, MA, USA
Posts: 609
Default not implemented: MIT-SHM/X_ShmCreatePixmap - do I miss a config option here?

I have a Windows app that worked in cedega's version of wine for years. Somewhere along the line it broke, now I get:
Code:
X Error of failed request:  BadImplementation (server does not implement operation)
  Major opcode of failed request:  147 (MIT-SHM)
  Minor opcode of failed request:  5 (X_ShmCreatePixmap)
  Serial number of failed request:  3574
  Current serial number in output stream:  3576
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0x500034f
  Serial number of failed request:  3581
  Current serial number in output stream:  3582
I do have SHM:
Code:
xdpyinfo ->
number of extensions:    29
[...]
    MIT-SHM
The "invalid pixmap or window parameter" is more likely to be the fatal one anyway, I think cedega continues after not finding MIT-SHM.

Now, I run an old X11 server here (7.1.1) but I get the same errors (both errors) on Xorg server 1.4.2.

%%

They do share the NVidia driver version (256.35) and the same Xorg.conf configuration. So the question is, could this be rooted in a NVidia driver update and/or did I forget to load a thing or other in Xorg.conf?


Config file and the logfiles for both new and old version are here:
http://www.cons.org/xorg-debug-201008/


Here are a whole bunch of pages with similar problems, but no solutions:
google search
__________________

My Unix benchmark results
uOpt is offline   Reply With Quote