View Single Post
Old 08-29-10, 02:18 AM   #1
paulw
Registered User
 
Join Date: Aug 2010
Posts: 3
Default Cannot set 1920x1080 resolution on GeForce4 MX 44 AGP8X

I have installed the Nvidia driver (96.43.18) for my graphics card to get 3D graphics acceleration running Fedora 13. This has worked fine! However...

The maximum resolution that the Nvidia X Server Settings app allows me to set is 1600x1200 - this is not ideal for my widescreen monitor which supports 1920x1080. (ViewSonic VX2433wm). I can get 1920x1080 using the "nv" driver, so it is clearly not a hardware issue.

Here is my xorg.conf - I have tinkered with it a lot with no success, and have restored it back to the original file (more or less).
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder63) Tue Jul 13 13:32:36 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic VX2433wm"
HorizSync 24.0 - 82.0
VertRefresh 50.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 MX 440 with AGP8X"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1600x1200 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
I have attached the nvidia bug report.

Any help would be greatly appreciated!

Paul
paulw is offline   Reply With Quote