View Single Post
Old 08-30-10, 11:35 PM   #11
micronux
Registered User
 
Join Date: Aug 2010
Posts: 1
Unhappy Re: Bad Video colours with 180.22

Quote:
Originally Posted by gbil View Post
This is probably an old bug with gstreamer.

when you hit this issue run

> xvattr -a XV_HUE

and see the output. If it is anything else than 0, run

> xvattr -a XV_HUE -v 0

and see what happens
Hi guys, I come back on this thread to tell you that this do the the trick for me as well but its not permanent. I have to do it again and again each time i start a video, whatever the media player is.

Another inetresting fact is when i open the "NVIDIA X Server Setting" via "System=>Administration" (Yes i'm using Ubuntu 10.04 LTS with Gnome) in the section "X Server XVideo Settings", the Hue is set to 0 but when i launch the command :

$ xvattr -a XV_HUE

The result is :
Found Xv 2.2
XV_HUE = -1000

Either i click the "Reset Hardware Defaults" button or i launch
$ xvattr -a XV_HUE -v 0
it resolve the problem but just for the video i just start.

If i close the video player and start the video again, the HUE setting come back to -1000 and the NVIDIA HUE setting still show me 0.

I know how to workaround the problem, but how to make it permanent ??

Thanks a lot for helping me guys.

PS : i'm using the NVIDIA GeForce 9500 GT with 2 screens (it works great actually) and NVIDIA Driver Version : 195.36.24

Here is my /etc/X11/xorg.conf

Quote:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 22 11:44:23 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9500 GT"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9500 GT"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1440+0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +1440+0, DFP: nvidia-auto-select +0+0"
# Removed Option "TwinViewXineramaInfoOrder" "DFP-0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-1"
Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1440+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
If its just a matter of a little option in the Xorg, Which one is it ??

Thanks again !
micronux is offline   Reply With Quote