View Single Post
Old 09-08-10, 05:48 PM   #1
ocgltd
Registered User
 
Join Date: Jul 2007
Posts: 10
Default Starting X always switches nvidia driver to vesa

I have a GeForce 8600 GT in my Fedora 12 system. Everything worked great for a year, and I then I upgraded the motherboard, now the system will not use the Nvidia driver! This is a really strange one.

I have the latest nvidia drivers installed (NVIDIA-Linux-x86-256.53.run), nouveau blacklisted, etc. And modinfo shows the nvidia driver is installed. (See below)

Strangely, whenever I start X (telinit 5), the vesa driver loads! As well, all of the instances of 'Driver "nvidia"' gets switched to 'Driver "vesa"' in the xorg.conf !!! Why/what is changing this line automatically?

I tried removing my xorg.conf and using a simple one created by the nvidia installer, but it made no difference. That one too has the 'Driver "nvidia"' line switched to 'Driver "vesa"' during X start.

I've messed with this for hours. Can anyone help? Why won't the nvidia driver run!!! my xorg.conf is below, and so is the Xorg.0.log.

Thanks



MODINFO NVIDIA:
Code:
filename:       /lib/modules/2.6.32.21-166.fc12.i686/kernel/drivers/video/nvidia.ko
alias:          char-major-195-*
supported:      external
license:        NVIDIA
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        i2c-core
vermagic:       2.6.32.21-166.fc12.i686 SMP mod_unload 686 
parm:           NVreg_EnableVia4x:int
parm:           NVreg_EnableALiAGP:int
parm:           NVreg_ReqAGPRate:int
parm:           NVreg_EnableAGPSBA:int
parm:           NVreg_EnableAGPFW:int
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_UseVBios:int
parm:           NVreg_RMEdgeIntrCheck:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_NvAGP:int
XORG.CONF
Code:
Section "ServerLayout"
        Identifier     "dual head configuration"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" 0 0
        InputDevice    "EETI" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option      "Xinerama" "0"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
        Option      "AIGLX" "on"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbLayout" "us"
        Option      "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
#    Option         "Device" "/dev/input/mice"
        Option      "Device" "/dev/input/mouse1"
        Option      "Emulate3Buttons" "no"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
        Identifier  "EETI"
        Driver      "egalax"
        Option      "Device" "usbauto"
        Option      "Parameters" "/var/lib/eeti.param"
        Option      "ScreenNo" "0"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "SilverstoneTek"
        ModelName    "Chassis"
        HorizSync    28.0 - 55.0
        HorizSync    28.0 - 110.0
        VertRefresh  43.0 - 72.0
        VertRefresh  43.0 - 150.0
        ModeLine     "800x480_60" 29.6 800 832 944 976 480 490 495 505
        ModeLine     "1280x720_60" 73.8 1280 1312 1592 1624 720 735 742 757
        Option      "DPMS"
EndSection

Section "Monitor"

#    HorizSync       31.5 - 57.0
#    VertRefresh     50.0 - 75.0
        Identifier   "Monitor1"
        VendorName   "Sony"
        ModelName    "VPL-HS51"
        HorizSync    15.0 - 600.0
        VertRefresh  15.0 - 600.0
        Option      "dpms"
     # Generic - below
#     ModeLine "1280x720_75" 74.25 1280 1720 1760 1980 720 725 730 750 +HSync +VSync
#    Modeline "1280x720_75" 74.250 1280 1360 1488 1664 720 723 728 748 -hsync +vsync
#    Modeline "1280x720_75" 74.48 1280 1336 1472 1664 720 721 724 746 +hsync
#    Modeline "1280x720_60" 60.46 1280 1328 1456 1632 720 721 724 741 +hsync 
        Option      "UseEDIDFreqs" "FALSE"
        Option      "NoBandWidthTest" "TRUE"
EndSection

Section "Device"

    # do not use the frequencies provided by the monitor edid 
        Identifier  "Device1"
        Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
        BoardName   "GeForce 8600 GT"
EndSection

Section "Device"
        Identifier  "Device0"
        Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
        BoardName   "GeForce 8600 GT"
        Option      "ConnectedMonitor" "CRT-0, TV-0"
EndSection

Section "Screen"
        Identifier "Screen1"
        Device     "Device1"
        Monitor    "Monitor1"
        DefaultDepth     24
        Option      "TVStandard" "HD720p"
        Option      "AddARGBGLXVisuals" "True"
#    Option         "metamodes" "CRT: 1280x720_60 +0+0, TV: 1280x720_60 +0+0"
        Option      "metamodes" "CRT: 1280x720_60 +0+0, TV: 1280x720_60 +0+0"
        SubSection "Display"
                Depth     24
                Modes    "1280x720_75" "1280x720_60" "1280x720" "1280x768"
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Device0"
        Monitor    "Monitor0"
        DefaultDepth     24
        Option      "TVStandard" "HD720p"
        Option      "TwinView" "1"
        Option      "TwinViewXineramaInfoOrder" "CRT-0"
        Option      "metamodes" "CRT: 1280x720_60 +0+0, TV: 1280x720 +0+0"
        SubSection "Display"
                Depth     24
                Modes    "1280x720_60" "800x480_60" "1280x720_75" "1280x768" "1280x720"
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Enable"
EndSection
Attached Files
File Type: log Xorg.0.log (53.1 KB, 74 views)
File Type: gz nvidia-bug-report.log.gz (63.8 KB, 76 views)
ocgltd is offline   Reply With Quote