View Single Post
Old 09-13-10, 03:44 PM   #1
Surmoka
Registered User
 
Join Date: Jan 2006
Posts: 11
Default Stubborn VBLANK with vdpau (fullscreen?)

Hi,

I can't exactly trace down the cause of what I'm experiencing, but:
* Fedora 9, kernel 2.6.32.2
* NVIDIA driver version: 256.53
* Video card: GeForce 8600 GT
* mplayer SVN-r32049-snapshot-4.3.0 (few days old svn)
* Compiz (but "unredirect fullscreen windows" is enabled)
* monitor refresh rate: 60 Hz

and when playing back any video with VDPAU in fullscreen, nothing can go above my monitor refresh rate. No matter how high of an FPS is specified for mplayer, it is capped at 60 (and I really mean it, the video's time is elapsing at 60 fps only). This makes me think that sync to vblank is enabled. Is there any way to disable it for VDPAU? Sync for vblank is not set, neither for Xv nor for GL.
As I live in Europe, this 60Hz vsync is causing stuttering for my 50Hz TV broadcasts because 60 is not a multiple of 50.

This is only half of the things. If not VDPAU (or not fullscreen), the effect seems similar, except that fps is not capped at 60 but refresh still never seems to happen anywhere mid-screen and stuttering is present with all mplayer video outputs, which means refresh is still synced to vblank, apparently at a more generic level.

Could someone help me out on what vsync setting may still be active and how to disable it?
As this post is not really a bug report or the like, I'm not attaching debug infos - I've scanned through them and they don't seem to provide relevant information for this case.
My Xorg log is here anyway.

Thanks in advance.
Attached Files
File Type: txt Xorg.0.log.txt (19.0 KB, 74 views)
Surmoka is offline   Reply With Quote