View Single Post
Old 10-21-10, 12:57 PM   #5
NinjaNumberNine
Molten CPU Generator
 
NinjaNumberNine's Avatar
 
Join Date: Oct 2010
Location: another console
Posts: 26
Default Re: GeForce 7300 LE w/Kubuntu 10.04/10.10 : My personal nightmare

Don't get me wrong- Dad is very computer-literate, in fact, he started me off with linux in the first place. Since most of his trading software was windows only, he stayed with XP himself, but encouraged me to find substitutes in Linux. So we finally made the switch and he's been enjoying it, it's just that the bugs are irritating and numerous at times. I run Kubuntu myself with no problems, (intense gaming, desktop effects, programming, graphics design, 3D modeling, etc) on my pc, but i'm just using an on-board Intel graphics chip (which does fine). Adding dual head cards, proprietary drivers and the like adds an entirely new headache. Dad needs dual monitors to invest/trade efficiently, thus the graphics card, and thus the issues that come with it.

Oh and he really wants to use linux- try and understand that. He has to support our family of 11 (and we're NOT on welfare or in debt, or poor) entirely on the computer, so you can see the need for a stable (and secure) OS. (And we get plenty of help from God too)

Back on topic... i ran 'sudo apt-get purge nvidia*' which completely removed all the nvidia drivers/config. Then i installed the nouveau drivers, and now I am back with a gui (and no xorg.conf) that looks nice and normal, except there is no tv card playback (driver issue i'm guessing) and compiz won't work with the following reasons (as generated by compiz-check):
Code:
Gathering information about your system...

 Distribution:          Ubuntu 10.10
 Desktop environment:   KDE4
 Graphics chip:         nVidia Corporation G72 [GeForce 7300 LE] (rev a1)
 Driver in use:         nouveau
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [FAIL]

There has been (at least) one error detected with your setup:
 Error: Software Rasterizer in use
I believe the reason for this is that (quote from this page): Support for this sort of 3D operation is blocked by TTM and texture support. Don't expect compiz to work at all until at least 2007Q4.
Any thoughts? I'll try nvidia again if i get some positive input.
NinjaNumberNine is offline   Reply With Quote