View Single Post
Old 11-04-10, 06:23 PM   #2
zooz
Registered User
 
Join Date: Nov 2010
Posts: 8
Default Re: [260.19.12 9600M GT regression] Adaptive scaling/speed issues in fedora 14

Yay! Finally I have found a temporary solution to addressing this very annoying issue.

Basically what I have managed to discover is that it's not the issue with Nvidia drivers neither is with Xorg itself, but it's the issue with 2D rendering library libcairo.so.

Fedora 14 ships with cairo-1.10.0-1.fc14 which is somehow broken with recent nvidia drivers, no matter is you use binary ones from nvidia.com nor the packaged kmod-nvidia ones.

So the temporary solution, which I could suggest doing is to downgrage the cairo to 1.8.x version as well as cairomm package.

Quick instructions how to do it:

1. Add fedora13 and fedora13-updates repos

/etc/yum.repos.d/fedora-13.repo
----------------------
[fedora13]
name=Fedora 13 - $basearch
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/13/Everything/$basearch/os/
enabled=1
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
----------------------

/etc/yum.repos.d/fedora-13-updates.repo:
----------------------
[f13-updates]
name=Fedora 13 - $basearch - Updates
failovermethod=priority
baseurl=http://mirror.bytemark.co.uk/fedora/linux/updates/13/$basearch/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
----------------------

2. Do the actual downgrade of cairo and cairomm

yum --nogpgcheck --noplugins --disablerepo=* --enablerepo=fedora13 downgrade cairo.x86_64 cairomm.x86_64

(supposedly you run 64bit version of Fedora).

3. Restart your xorg server and off you go - the issue is resolved
zooz is offline   Reply With Quote