View Single Post
Old 11-06-10, 10:46 PM   #1
Vhann
Registered User
 
Join Date: Nov 2010
Posts: 3
Default How to delete a specific refresh rate from xrandr?

Hi,

Problem description
I'm trying to play Windows games on my GNU/Linux machine. Some of these games try to change the resolution from 1024x768 to 640x480 (for example). But the problem is that when the games do that, all I get is a blank screen with a flashing LED (indicating some kind of error).

Also, when I switch to a terminal and issue 'DISPLAY=:0.0 xrandr -s 0' to get a working resolution back, all I get is GDM (login prompt).

I have found by doing tests that issuing 'xrandr --output default --mode "640x480" ' gets me the flashing LED and blank screen while 'xrandr --output default --mode "640x480" --rate 62' gets me a working 640x480 resolution. I can also play the game in Wine's virtual desktop (so I know everything works correctly).


Tried solutions
-Tried using 'nvidia-xconfig', it doesn't solve the problem.
-Tried using 'nvidia-settings -r', it doesn't work;
-Tried asking #xorg on freenode, but they don't support the closed-source nVidia driver

Question
So my question is: is there a way to make 62 Hertz the 'preferred 640x480 refresh rate'? Or delete specific refresh rates? Or, even, is there a better way to fix my problem I could have missed?


Regards,
Vhann

==================
Here are my system details:
Ubuntu 9.10 Karmic Koala

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"

$ dpkg --get-selections | grep nvidia
nvidia-185-kernel-source install
nvidia-185-libvdpau install
nvidia-common deinstall
nvidia-glx-173 deinstall
nvidia-glx-185 install
nvidia-settings install

/etc/X11/xorg.conf:
Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Fri Aug 14 17:54:58 PDT 2009


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "IBM Monitor"
EndSection

Section "Device"
Identifier "Nvidia Geforce 6200"
Driver "nvidia"
EndSection

Section "Screen"

#SubSection "Display"
# Modes "1024x768" "800x600"
#EndSubSection
Identifier "Default Screen"
Device "Nvidia Geforce 6200"
Monitor "IBM Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Depth 24
# Modes "nvidia-auto-select"
EndSubSection
EndSection
Vhann is offline   Reply With Quote