View Single Post
Old 11-09-10, 04:41 AM   #9
luk1don
Registered User
 
luk1don's Avatar
 
Join Date: Nov 2008
Posts: 55
Default Re: Newly installed 96.43.19 driver won't work

You should have the file: nvidia-bug-report.log.gz in your home folder.
Show output of "dmesg" command else.
(96.43.18 is incompatible with X.org server 1.9)
To many errors, but like X-es does not start on nvidia this may be the KMS and a framebuffer problem. Try to add options to kernel line like:
vga=791 (supported framebuffer of course)
vga=normal
Option: nomodeset too.
Quote:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e82fb]
1: /usr/bin/X (mieqEnqueue+0x1ab) [0x80e7aeb]
2: /usr/bin/X (xf86PostMotionEventP+0xd2) [0x80c2172]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0x500000+0x4961) [0x504961]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0x500000+0x4a56) [0x504a56]
5: /usr/lib/xorg/modules/input/evdev_drv.so (0x500000+0x5296) [0x505296]
6: /usr/bin/X (0x8048000+0x6951f) [0x80b151f]
7: /usr/bin/X (0x8048000+0x126aee) [0x816eaee]
8: (vdso) (__kernel_sigreturn+0x0) [0xb74400]
Wait for NVIDIA, probably this is a xorg 1.9 bug but with KMS of intel, nouveau, radeon - disable KMS in kernel (nomodeset).
Quote:
Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
I have this warning too, but everything works.
Quote:
(II) NVIDIA(0): Initialized GART.
(WW) NVIDIA(0): WAIT (2, 7, 0x8000, 0x0000d5f8, 0x0000e4a0)
(WW) NVIDIA(0): WAIT (1, 7, 0x8000, 0x0000d5f8, 0x0000e4a0)
(II) NVIDIA(0): Initialized GART.
This may be a hardware problem, e.g. with the radiator but gart is initializing.
luk1don is offline   Reply With Quote