View Single Post
Old 11-16-10, 12:25 PM   #1
frix
Registered User
 
Join Date: Jun 2010
Posts: 5
Default patch for nvidia 260.9.14 (CUDA) on rt-linux 2.6.33.7-rt29

The nvidia propriety driver doesn't build against the linux kernel with the -rt (real-time) patch applied.
Searching the web, I've found a patch for nvidia 256.44 on linux 2.6.33.7-rt29 at
http://www.spinics.net/lists/linux-r.../msg05998.html
Small changes were required to get the patch working on 260.9.14.

I've attached the updated patch.
Apply the patch as follow to the nVidia driver (assuming that you're using the nVidia driver with CUDA development support)
1) ./devdriver_3.2_linux_32_260.19.14.run --extract-only
2) cd /tmp/NVIDIA_Linux-x86-260.19.14/kernel
3) Move the patch to this directory
4) Apply the patch: cat patch.txt | patch -p2
The output should state: patching file nv-linux.h
5) cd ..
6) Build the module:
./nvidia-installer -K --kernel-name=2.6.33.7-rt29

This was all that was required for me.
Good luck.
Attached Files
File Type: txt path.txt (203 Bytes, 240 views)
frix is offline   Reply With Quote