View Single Post
Old 12-03-10, 08:29 AM   #82
TaylorT
Registered User
 
Join Date: Oct 2009
Posts: 8
Default Re: Linux backlight driver

Quote:
Originally Posted by guillaumezin
The 0.55 version should compile on Ubuntu 10.04 too
Version 0.55 worked fine for me with 10.04.

Quote:
Originally Posted by guillaumezin
The complete VPCCW1 family should be supported now.
It doesn't work with all Sony VPCCW1* laptops, however. I had to make the following changes to get it working for my Sony VPCCW17FX (NVidia g210m):

nvidiabl-laptops.h:
Code:
// This has to be BEFORE the general VPCCW1 line
NVIDIABL_DECLARE_LAPTOP_MODEL("Sony Corporation", "VPCCW17FX", 0x0a74, 0, 1024, 127000),
NVIDIABL_DECLARE_LAPTOP_MODEL("Sony Corporation", "VPCCW1", 0x0a2a, 0, 7000, 2500000),
nvidiabl-models.c:
Code:
/* NVIDIA Quadro FX 470 */
{ PCI_VDEVICE(NVIDIA, 0x087f), (kernel_ulong_t)&nv5x_driver_data },
/* NVIDIA GeForce 210M */
{ PCI_VDEVICE(NVIDIA, 0x0a74), (kernel_ulong_t)&nv5x_driver_data },
/* NVIDIA GeForce 230M */
{ PCI_VDEVICE(NVIDIA, 0x0a2a), (kernel_ulong_t)&nv5x_driver_data },
Now if i could only get it to not conflict with the sony-laptop module it would be perfect

--Taylor

Last edited by TaylorT; 12-03-10 at 08:31 AM. Reason: corrected filename
TaylorT is offline   Reply With Quote