View Single Post
Old 12-14-10, 10:23 AM   #1
RAMChYLD
Registered User
 
Join Date: Feb 2005
Location: Malaysia
Posts: 95
Default Error inserting nvidia: invalid argument

Hi all,

I just upgraded my kernel to 2.6.36.2, and attempted to build the nvidia module 96.43.19. The module builds with no noticable errors, but when I tried to install it, I got the following error:

WARNING: "i2c_add_adapter" [/usr/src/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/nvidia.ko] undefined!
WARNING: "i2c_del_adapter" [/usr/src/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/nvidia.ko] undefined!
...
WARNING: -e needs -E or -F
...
FATAL: Error inserting nvidia (/lib/modules/2.6.36.2.clem/kernel/drivers/video/nvidia.ko): Invalid argument

I have already tried modprobing i2c-core prior to re-attempting to modprobe the module with no success. Any time I tried to re-modprobe the module I only got the FATAL: error repeated.

Afaik, the kernel module built fine and loaded under 2.6.36.1. No options were changed in the building of the 2.6.36.2 kernel (copied the config file over from the 2.6.36.1 source and make oldconfig && make prepare && make bzImage && make modules).

This rig runs Debian Sid with a customized kernel (tuned for low latency and to enable HPET, I use Rosegarden on it) and it uses a GeForce4 440MX 8X video card.

Please help :/
__________________
Rigs:
  • "Edison" - Phenom II X4 925 AM3 (Deneb), M4N98TD-EVO (nForce980a SLI), ENGTS450 DirectCU 1GB (GeForce GTS450) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 8GB DDR3-1600
  • "Sally" - Athlon64 x2 5000+ AM2 (Brisbane), M4N72-E (nForce750a SLI), ENGTS250 Dark Knight 1GB (GeForce GTS250) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 4GB DDR2-1066
  • "Dongwa" - Phenom II X4 945 AM3 (Deneb), M4N75TD (nForce750a SLI), ENGTX260-216SP 896MB (GeForce GTX260 216SP) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Fatal1ty Champion, 8GB DDR3-1600
  • "Helen" - Athlon64 x2 6400+ AM2 (Windsor), M4N78 Pro (GeForce8300), ENGT520 1GB (GeForce GT520), integrated GeForce8300, AuzenTech Prelude X-Fi, 4GB DDR2-1066.
  • "Clementine" - Athlon64 x2 3800+ AM2 (Windsor), TF560A2+ (nForce560), V8402GL26 (GeForce 8400GS), SoundBlaster Live! 5.1, Sonnet Allegro FW400 PCIe, 2GB DDR2-800
RAMChYLD is offline   Reply With Quote