View Single Post
Old 12-22-10, 11:46 AM   #4
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by nlamarra View Post
After some messing around, including some good (and bad) advice from nVidia support, including the following link, I was able to get 5.1-ch sound in some circumstances:

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

the trick for my setup was to add the following line to /etc/modprobe.d/sound.conf:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

and then use the device:

plughw:0,7

So now I can get 5.1-sound using:

speaker-test -D plughw:0,7 -c6

and I can even get other output sample rates (e.g., 48, 96, 192KHz) like:

speaker-test -D plughw:0,7 -c6 -p 1000000 -t sine -r 192000 -f 1000

However, System->Preferences->Sound still shows the only available device as "HDMI stereo", and I only get 2-channel audio from rhythmbox, even with multi-channel .flac files.

And I also still get absolutely no sound from mplayer or xine.

Sorry for my ignorance, but how do I get these other applications to understand the equivalent of plughw:0,7, or set the default sound hardware device to this?

Thanks
Correction: I've just discovered that mplayer does produce 2-ch sound from a .TS file (at 1920x1080), but the audio should be 5.1 LPCM 48KHz. I've tried:

mplayer -ao alsa:device=plughw=0.7 file.TS

but this still produced 2-ch 44.1KHz sound.

Any suggestions on how to change the alsa device System-wide so every application knows it's capable of 5.1ch?
nlamarra is offline   Reply With Quote