View Single Post
Old 12-22-10, 02:16 PM   #5
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default Re: HDMI audio finally working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by nlamarra View Post
Correction: I've just discovered that mplayer does produce 2-ch sound from a .TS file (at 1920x1080), but the audio should be 5.1 LPCM 48KHz. I've tried:

mplayer -ao alsa:device=plughw=0.7 file.TS

but this still produced 2-ch 44.1KHz sound.

Any suggestions on how to change the alsa device System-wide so every application knows it's capable of 5.1ch?
More experimentation and searching has produced success! Here are the additional things that helped. First, adding the following to /etc/asound.conf allowed me to set the default device to plughw:0,7 as follows:

pcm.!default {
type plug
slave.pcm {
type hw
card 0
device 7
}
}


This enabled rhythmbox to produce 2-ch audio LPCM 48KHz by default.

To enable it to play AVCHD files in 1920x1080 @ 5.1-ch audio for mplayer, I used:

mplayer -ao alsa:device=plughw=0.7 -channels 6 file.TS

and finally, for DVDs:

xine -A alsa

I still haven't figured out how to get 5.1audio from xine, because when I enter the audio control panel to select "speaker selection", the control hangs, so it won't let me scroll down to 5.1 surround. However, 2-ch output occurs via HDMI. There's probably a way to configure this in a config file using --config<file> but I haven't figured this out yet.

Just for completeness in this post, the other settings I had to make were in /etc/pulse/default.pa:

load-module module-alsa-sink device=plughw:0,7


and in /etc/modprobe.d/sound.conf:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

and I figured out the card 0 and device 7 from running

aplay -l

which produced the following output:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


and trying device 3, 7, 8, 9 in turn led me to discover that 7 was needed for 5.1-ch audio.

Final test:

speaker-test -c6

now works without my having to add the option "-D plughw:0,7", meaning that my default audio device is correctly set to plughw:0,7 by the above.

Thanks for all the suggestions and I hope this experience is helpful to other newbies.
nlamarra is offline   Reply With Quote