View Single Post
Old 12-23-10, 08:11 AM   #1
jackLNX
Registered User
 
Join Date: Dec 2010
Posts: 3
Exclamation X server 1.9.3 crash on Fedora 14, GeForce 8600 GTS

Problem: Crash after a few minuts (sometime a few seconds) after Gnome login.
Description: Screen freeze, mouse stuck and after a few second the screen turns black. Ctrl+Alt+F1/F2/F3 etc. don't work.

All updated to the latest version:
Nvidia Driver for Linux 32bit version 260.19.29
Kernel 2.6.35.10-72.fc14.i686
xorg-x11-server 1.9.3-3.fc14

I attached 2 bug report, the first obtained immediately after reboot at runlevel3. The second obtained at runlevel5 (nvidia-bug-report gets some informations from the X server)

I started X with 'startx -- -logverbose 6', but it didn't show any particular error.
Instead var/log/messages shows:
Code:
Dec 23 12:22:33 localhost kernel: [   11.039468] NVRM: loading NVIDIA UNIX x86 Kernel Module  260.19.29  Wed Dec  8 12:09:09 PST 2010
Dec 23 12:25:03 localhost kernel: [  165.059132] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:03 localhost kernel: [  165.059135] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:03 localhost kernel: [  165.059147] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:03 localhost kernel: [  165.059148] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:03 localhost kernel: [  165.059158] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:03 localhost kernel: [  165.059159] NVRM: os_pci_init_handle: invalid context!
Dec 23 12:25:10 localhost kernel: [  172.390162] NVRM: Xid (0002:00): 16, Head 00000001 Count 00000000
Additional notes:
_ I installed successfully the driver on my notebook(Geforce Go 7300, same OS and driver version) and I noticed, at Gnome startup, the Nvidia logo which doesn't show up in my PC (and I didn't set the --no-logo option)
_ I tried to add pci=nommconf, idle=poll maxcpus=1, clocksource=hpet, acpi=off to the kernel line. Nothing changed.
_ Run glxgears causes the crash immediately after a few frames.
Attached Files
File Type: zip nvidia-bug-report_runlevel3_logverbose_6.zip (46.8 KB, 59 views)
File Type: zip nvidia-bug-report_runlevel5.zip (41.2 KB, 49 views)

Last edited by jackLNX; 12-24-10 at 10:54 AM.
jackLNX is offline   Reply With Quote