View Single Post
Old 12-26-10, 12:46 PM   #1
Ad0
Registered User
 
Join Date: Feb 2009
Posts: 17
Default Drivers >= 256.x issues on 220GT

Hi, I have a fanless 220GT, and I have problems when changing to 60Hz, and some issues with vdpau:

Refresh rate change: Changing to 60Hz makes the TV go black with / without apps running in ubuntu 9.10 X Windows. Sound also goes completely dead until I reboot.

VDPAU: Sometimes white dots occurs when there's black and it won't remedy itself until I reboot / cold boot. Doesn't matter whether there's h264 or mpeg2.

Works perfectly on 195.36.31.

Tried with different X configs on:

NVIDIA-Linux-x86-256.29.run
NVIDIA-Linux-x86-256.35.run
NVIDIA-Linux-x86-260.19.21.run
NVIDIA-Linux-x86-260.19.29.run

X config:

Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "glx"
    Disable        "dri2"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SONY TV XV"
    DisplaySize     339    212
    HorizSync       14.0 - 70.0
    VertRefresh     23.0 - 62.0
    ModeLine       "1920x1080@24" 74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "1920x1080@50" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "1920x1080@50i" 63.10 1920 1952 2184 2216 1080 1105 1110 1135 +hsync +vsync interlace
    ModeLine "1920x1080@59.94" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    ModeLine "1920x1080@60" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync


 #   ModeLine       "1920x1080@60" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

    Option         "ExactModeTimingsDVI" "True"
#    Option         "ModeValidation" "NoEdidModes"
#    Option         "UseEDIDDpi" "False"
#    Option         "UseEDIDFreqs" "False"
#    Option         "RenderAccel" "True"
#    Option         "AllowGLXWithComposite" "true"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"

#       Option "TripleBuffer" "True"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "FlatPanelProperties" "Scaling = Native"
    Option         "AllowGLXWithComposite" "true"
    Option         "PixmapCacheSize" "1000000"
    Option         "PixmapCacheRoundSizeKB" "1024"
    Option         "AllowSHMPixmaps" "0"
    Option         "CoolBits" "1"
    Option         "ExactModeTimingsDVI" "true"
    Option         "NoLogo" "true"
    Option         "DynamicTwinView" "false"
    Option         "ModeValidation" "NoVesaModes, NoEdidModes, NoXServerModes, NoPredefinedModes"
    Option         "DisableGLXRootClipping" "True"
    Option         "IgnoreEDID" "True"
    Option         "DPI" "96 x 96"
    Option         "NvAGP" "1"
    Option         "UseEvents" "True"
    Option         "RenderAccel" "true"
    SubSection     "Display"
#               Modes      "1920x1080@50i"
        Depth       24
        Modes      "1920x1080@50" "1920x1080@60" "1920x1080@24"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
Any help would be appriciated, cause I'd like to stay updated on drivers.
Ad0 is offline   Reply With Quote