View Single Post
Old 11-25-03, 04:38 AM   #1
devjam
Registered User
 
Join Date: Nov 2003
Posts: 4
Question nvnet doesnt work after update ...

hi,

first of all my system:
- MSI K7N2-Delta ILSR
- AMD Athlon XP 2500+
- NVidia GForce 4 MX440
- SUSE Linux 9.0
and me:
NEWBEE

With some help of a friend i installed the following driver to get network connection:
NVIDIA_nforce-1.0-0261.suse90.i586.rpm

After we got it work, i called the SUSE-Linux-Online-Update
and installed all patches that were possible.
There has been a patch for NVIDIA, a Kernel-Patch for AMD-CPUs
and some other patches. So after this patches and reboot i am
not more possible to connect to internet.

I am newbee on Linux!

if i type "ifconfig" on shell i get this:

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:3912 (3.8 Kb) TX bytes:3912 (3.8 Kb)

if i'm looking on the details of networkadapter in SUSEplugger
i see that the name of the adapter is correct.
status is: availability = yes
configured = no
driver info:

Driver Info #0:
Driver Status: nvnet is not active
Driver Activation Cmd: "modprobe nvnet"

if i type "modprobe nvnet" into a shell i get this:

Using /lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_Ra7000325
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rd36c0dd3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R9ee181c3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_R6d8f9943
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_Rfadb88b1
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Rdee41f6c
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_Raebda71a
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.


please help me, i don't know what to do or what i am doing wrong.
i tried to reinstall the driver but it seems not working

thanx a lot
devjam is offline   Reply With Quote