View Single Post
Old 02-15-11, 04:19 AM   #5
Tatzelwurm
Registered User
 
Tatzelwurm's Avatar
 
Join Date: Feb 2011
Location: Cologne
Posts: 5
Default Re: X server 1.9.3 crash on Fedora 14, GeForce 8600 GTS

Fedora 14 x64 and GeForce 8600 GT do not work properly.

Short:
GDM Login = OK
Gnome Desktop = OK
Most gnome programs = OK
KDE Desktop = crash
Most KDE programs = crash
kPackageKit, LabView, eagle, .... = crash

xorg.0.log
Code:
[  1313.325] 
X.Org X Server 1.9.3
Release Date: 2010-12-13
[  1313.325] X Protocol Version 11, Revision 0
[  1313.325] Build Operating System: x86-18 2.6.32-71.el6.x86_64 
[  1313.326] Current Operating System: Linux Elektra.AC.uni-koeln.de 2.6.35.11-83.fc14.x86_64 #1 SMP Mon Feb 7 07:06:44 UTC 2011 x86_64
[  1313.326] Kernel command line: ro root=UUID=eab1cf97-17af-436e-8c3d-7852b5ff7f7e rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=de_DE.UTF-8 KEYTABLE=de-latin1 rdblacklist=nouveau vga=0318 pcie_aspm=off
[  1313.326] Build Date: 14 January 2011  12:48:20AM
[  1313.326] Build ID: xorg-x11-server 1.9.3-4.fc14 
...
[  1314.624] (II) Loading sub module "ramdac"
[  1314.624] (II) LoadModule: "ramdac"
[  1314.624] (II) Module "ramdac" already built-in
[  1314.624] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  1314.624] (==) NVIDIA(0): RGB weight 888
[  1314.624] (==) NVIDIA(0): Default visual is TrueColor
[  1314.624] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1314.624] (**) NVIDIA(0): Option "TwinView" "1"
[  1314.624] (**) NVIDIA(0): Option "MetaModes" "CRT: 1600x1200_85 +1920+0, DFP: 1920x1200_60 +0+0"
[  1314.624] (**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "DFP-1"
[  1314.624] (**) NVIDIA(0): Option "ConnectToAcpid" "off"
[  1314.625] (**) NVIDIA(0): Enabling RENDER acceleration
[  1314.625] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[  1314.625] (II) NVIDIA(0):     enabled.
[  1315.626] (II) NVIDIA(0): NVIDIA GPU GeForce 8600 GT (G84) at PCI:5:0:0 (GPU-0)
[  1315.626] (--) NVIDIA(0): Memory: 524288 kBytes
[  1315.626] (--) NVIDIA(0): VideoBIOS: 60.84.41.00.00
[  1315.626] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1315.626] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[  1315.626] (--) NVIDIA(0): Connected display device(s) on GeForce 8600 GT at PCI:5:0:0
[  1315.626] (--) NVIDIA(0):     Idek Iiyama HM204D DT (CRT-0)
[  1315.626] (--) NVIDIA(0):     Samsung SyncMaster (DFP-1)
[  1315.626] (--) NVIDIA(0): Idek Iiyama HM204D DT (CRT-0): 400.0 MHz maximum pixel clock
[  1315.627] (--) NVIDIA(0): Samsung SyncMaster (DFP-1): 330.0 MHz maximum pixel clock
[  1315.627] (--) NVIDIA(0): Samsung SyncMaster (DFP-1): Internal Dual Link TMDS
[  1315.629] (**) NVIDIA(0): TwinView enabled
[  1315.629] (II) NVIDIA(0): Display Devices found referenced in MetaMode: CRT-0, DFP-1
[  1315.704] (II) NVIDIA(0): Assigned Display Devices: CRT-0, DFP-1
[  1315.705] (II) NVIDIA(0): Validated modes:
[  1315.705] (II) NVIDIA(0):     "CRT:1600x1200_85+1920+0,DFP:1920x1200_60+0+0"
[  1315.705] (II) NVIDIA(0): Virtual screen size determined to be 3520 x 1200
[  1315.733] (--) NVIDIA(0): DPI set to (90, 92); computed from "UseEdidDpi" X config
[  1315.733] (--) NVIDIA(0):     option
[  1315.733] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[  1315.734] (--) Depth 24 pixmap format is 32 bpp
[  1315.734] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[  1315.735] (II) NVIDIA(0): Initialized GPU GART.
[  1315.741] (II) NVIDIA(0): Setting mode "CRT:1600x1200_85+1920+0,DFP:1920x1200_60+0+0"
[  1315.786] (II) Loading extension NV-GLX
[  1315.833] (II) NVIDIA(0): Initialized OpenGL Acceleration
[  1315.834] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1315.834] (II) NVIDIA(0): Initialized X Rendering Acceleration
[  1315.834] (==) NVIDIA(0): Backing store disabled
[  1315.834] (==) NVIDIA(0): Silken mouse enabled
[  1315.860] (**) NVIDIA(0): DPMS enabled
[  1315.860] (II) Loading extension NV-CONTROL
[  1315.861] (II) Loading extension XINERAMA
[  1315.861] (II) Loading sub module "dri2"
[  1315.861] (II) LoadModule: "dri2"
[  1315.862] (II) Reloading /usr/lib64/xorg/modules/extensions/libdri2.so
[  1315.862] (II) NVIDIA(0): [DRI2] Setup complete
[  1315.862] (==) RandR enabled
...
after start of any KDE program
Code:
[  1535.748] 
Backtrace:
[  1535.748] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x4a0488]
[  1535.748] 1: /usr/bin/Xorg (0x400000+0x60d79) [0x460d79]
[  1535.748] 2: /lib64/libc.so.6 (0x3eccc00000+0x33140) [0x3eccc33140]
[  1535.748] 3: /usr/bin/Xorg (doListFontsWithInfo+0x172) [0x42dfc2]
[  1535.748] 4: /usr/bin/Xorg (ProcessWorkQueue+0x21) [0x4318d1]
[  1535.748] 5: /usr/bin/Xorg (WaitForSomething+0x5b) [0x459edb]
[  1535.748] 6: /usr/bin/Xorg (0x400000+0x2d252) [0x42d252]
[  1535.748] 7: /usr/bin/Xorg (0x400000+0x2152e) [0x42152e]
[  1535.748] 8: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3eccc1ee5d]
[  1535.748] 9: /usr/bin/Xorg (0x400000+0x210d9) [0x4210d9]
[  1535.748] Segmentation fault at address 0x10
[  1535.748] 
Fatal server error:
[  1535.748] Caught signal 11 (Segmentation fault). Server aborting
[  1535.748] 
[  1535.748] 
Please consult the Fedora Project support 
	 at http://wiki.x.org
 for help. 
[  1535.748] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1535.748] 
[  1535.752] (II) Power Button: Close
[  1535.752] (II) UnloadModule: "evdev"
[  1535.756] (II) Power Button: Close
[  1535.756] (II) UnloadModule: "evdev"
[  1535.760] (II) Logitech USB Receiver: Close
[  1535.760] (II) UnloadModule: "evdev"
[  1535.764] (II) Logitech USB Receiver: Close
[  1535.764] (II) UnloadModule: "evdev"
I don't know where the problem is located, maybe driver, xorg, dri, ..........
Tatzelwurm is offline   Reply With Quote