View Single Post
Old 02-18-11, 02:32 AM   #16
Civilus
Registered User
 
Join Date: Apr 2008
Location: Russia, Moscow
Posts: 39
Send a message via ICQ to Civilus
Default Re: Freeze/X lockup during VDPAU playback

Stephen Warren
I've got 2 kinds of issues:
1) X sometimes (really sometimes - I don't figured out how to reproduce it with 100% chance) hangs at start, screen corruption before or just after modeswithch, after a while monitor turns off, like this: http://imageshack.us/photo/my-images/16/mg5197.jpg/ (pattern always same if it matters). I can ssh to machine but I don't think I can get any useful bugreport.

The last only error in Xorg.0.conf is:
[ 48.885] (EE) NVIDIA(0): WAIT: (E, 0, 0x857d, 0)

It boots only if I add NVreg_RegistryDwords="PerfLevelSrc=0x2222" to modules.d/nvidia.conf

I've attached nvidia-bugreport for this. Again.

p.s. backtrace when X hangs up at start:
Code:
#0  0x00007f71bf53ebdf in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#1  0x00007f71bf4dcc00 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#2  0x00007f71bf4dcee9 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#3  0x00007f71bf4cf430 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#4  0x00007f71bf4d28d8 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#5  0x00007f71bf844f06 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#6  0x00007f71bf8451ae in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#7  0x00007f71bf8384bf in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#8  0x0000000000434efb in AddScreen ()
#9  0x0000000000495536 in InitOutput ()
#10 0x000000000042469e in _start ()
So nothing useful. Where can I get debug symbols for nvidia_drv?
2) Blackscreen and possibly OOPS (almost always if PowerMizer is on). It reboots after a while, but I still can't get any backtraces. I don't have COM port on my mobo, and I don't have IEEE1394 on other machines, I've tried to set up kdump, but for some reason it doesn't work yet.

Any suggestions how to get some useful info?

Next thing I'll try is to recompile whole system with -O0 -g -ggdb and attach to hang X process with gdb, maybe I would manage to get something interesting with stacktrace/backtrace.
Attached Files
File Type: gz nvidia-bug-report.log.gz (78.9 KB, 51 views)
__________________
OS: Gentoo Linux, ~amd64. VideoCard: GeForce GTX 470. ASUS P8P67 Deluxe, 2x4GB DDR3-1600 CL9, Core i7 2600k.

Last edited by Civilus; 02-19-11 at 05:42 AM.
Civilus is offline   Reply With Quote