View Single Post
Old 02-19-11, 02:29 PM   #4
cihy
Registered User
 
Join Date: Feb 2011
Posts: 10
Default Re: Xine VDPAU troubles

Quote:
Originally Posted by crisalide View Post
"video jump" comes from the metronom and means that it detected a video drift that was not possible to compensate on further frames ("for small diffs try to interpolate, for big diffs: jump"). So:

1) Make sure your monitor's vertical refresh rate is at least equal to the video display frame rate (which is 2x video stream frame rate when using temporal deint)

2) Comment out the following, it only waste video mem:
#engine.buffers.video_num_frames:30

3) Change to the following:
video.output.vdpau_enable_inverse_telecine:0

4) Give the following a try (it'll default to stereo):
#audio.output.speaker_arrangement:Pass Through

If none of the above solves your problem, then see if it happens only on live TV or also from HD recording. If the latest, provide a video sample so i can try to reproduce.
thank you both for such quick replies.

really appreciate the help!

1) i cant change anything here afaik... the htpc is connected to my 55" samsung LCD

2) 3) 4) done... video still jumping.

(just curious, how would downsampling to stereo help vs pass through directly to my receiver? would this not just add on some transcode time ?)

i've ran things through mplayer again....

the Bell ExpressVu seems to change up the framerate quite often on their stream....
whenever the rate changes, i'm guessing? i get a pause.

mplayer somehow can compensate, and displays a warning message.

Code:
MPlayer SVN-r29237-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not open config files /root/.lircrc and /etc/lirc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.

Playing 00001.ts.
TS file format detected.
VIDEO MPEG2(pid=4625) AUDIO A52(pid=4628) NO SUBS (yet)!  PROGRAM N. 132
VIDEO:  MPEG2  1280x720  (aspect 3)  59.940 fps  24000.0 kbps (3000.0 kbyte/s)
==========================================================================
Forced video codec: ffmpeg12vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg12vdpau] vfm: ffmpeg (FFmpeg MPEG-1/2 (VDPAU))
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1280 x 720 (preferred colorspace: MPEG2 VDPAU acceleration)
VDec: using MPEG2 VDPAU acceleration as output csp (no 1)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x720 => 1280x720 MPEG2 VDPAU acceleration  [fs]
A:83216.4 V:83216.9 A-V: -0.491 ct: -0.072  89/ 44  3% 54%  1.0% 0 0 
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:83216.6 V:83217.1 A-V: -0.439 ct: -0.094 100/ 55  3% 57%  1.0% 0 0 
demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
Warning! FPS changed 47.952 -> 59.940  (-11.988010) [7]  %  1.0% 0 0 
A:83226.1 V:83226.1 A-V: -0.007 ct: -0.507 640/303  0% 46%  0.9% 0 0 
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:83226.3 V:83226.3 A-V:  0.018 ct: -0.502 650/313  0% 47%  0.9% 0 0 
demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
Warning! FPS changed 47.952 -> 59.940  (-11.988010) [7]  %  0.9% 0 0 
A:83227.3 V:83227.2 A-V:  0.090 ct: -0.474 707/370  0% 51%  0.8% 0 0 
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:83227.4 V:83227.3 A-V:  0.076 ct: -0.468 713/374  0% 51%  0.8% 0 0 
demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
Warning! FPS changed 47.952 -> 59.940  (-11.988010) [7]  %  0.8% 0 0 
A:83237.0 V:83236.9 A-V:  0.028 ct: -0.490 1287/613  0% 46%  0.8% 0 0 
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:83237.2 V:83237.1 A-V:  0.077 ct: -0.480 1297/623  0% 46%  0.8% 0 0 
demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
Warning! FPS changed 47.952 -> 59.940  (-11.988010) [7]  6%  0.8% 0 0 
A:83238.9 V:83238.4 A-V:  0.494 ct: -0.449 1373/699  0% 51%  0.8% 60 0
why cant i get these warnings on xine :/


Quote:
Try setting this instead of your current value:

engine.buffers.video_num_buffers:5000
tried this of course with many values (including this 5000 just now)
same effect.

'video jump' almost scrolling on my console screen.

i can record a 30 second sample maybe if any of you would feel up to checking it out.


edit :

here is a sample if anyone wants to look.
its mpeg the .ts is just directly from vdr (plays perfectly fine in my windows 'vlc' or mplayer on linux (and xbmc))
(just fyi, it 'video jumps' about 10 times for me in xine)

http://69.164.213.177/xine/00001.ts
cihy is offline   Reply With Quote