View Single Post
Old 02-28-11, 01:50 PM   #1
taril
Registered User
 
Join Date: Jan 2009
Posts: 8
Default KDE Desktop is frozen during cube rotation with direct rendering

Version: 1.0 (using KDE 4.6.0)
OS: Linux - openSuSE

NVIDIA driver 260.36 (tried with different versions with the same result, beta too)

Enable desktop effects, enable desktop cube (direct rendering is enabled by
default). Press Ctrl+F11 to get desktop cube effect, and rotate the cube with
the mouse. After press 'space'.
The desktop effects will be disabled after a while, you cant do anything, only
mouse works. If you turn off 'Direct Rendering' on the 'Special' tab of the
Desktop Effects Settings, everything works normally.

Reproducible: Always

Steps to Reproduce:
1. enable desktop effects
2. enable desktop cube effect
3. press CTRL+F11 and rotate the cube
4. press 'space' to get back the workspace

Actual Results:
The desktop is unmanageable, mouse works, but not continuously, after a while
the desktop effects will be disabled because of "slow animation" (bubble note)

Expected Results:
Desktop effects with direct rendering

OS: Linux (x86_64) release 2.6.37-22-desktop
Compiler: gcc

SOURCE: https://bugs.kde.org/show_bug.cgi?id=266182
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.2 KB, 77 views)
taril is offline   Reply With Quote