View Single Post
Old 03-09-11, 03:37 PM   #1
moenchmeyer
Registered User
 
Join Date: Oct 2007
Posts: 30
Default FX2800M - driver 260.19.44 - adaptive clocking not working

I run Opensuse 11.3 with KDE 4.5 on a Dell M6500 with a FX2800M video card and an i7 Q 840 processor. Kernel version is 2.6.34.7-0.7-default. More precise (uname -a):
2.6.34.7-0.7-default #1 SMP 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux.

I installed nvidia's driver 260.19.44. Afterwards I noticed that adaptive clocking is not working.

The graphics card always (!) runs with maximum speed, i.e.:
graphics clock at 600 MHz, memory clock at 1000 MHz, processor clock at 1500 MHz.

The 4 possible performance levels are displayed though. However, an automatic clock frequency reduction does not occur at any time.

This is in strong contrast to a FX 1800M on a Dell M4500. There the graphics card adaptively reduces its clock rates down to the lowest level when no 3d applications or only KDE's 3D effects are running.

I can reduce the clock rates manually via enabling coolbits in xorg.conf and reducing the clock rates by hand in the nvidia settings panel.

However, even settings as
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3333;"
in xorg.conf do not trigger an automatic adaptive clocking.

This is true also for beta driver 270.26.

Is this a driver problem or a defect of the graphics cards ?

Last edited by moenchmeyer; 03-09-11 at 05:26 PM. Reason: added more info on kernel version and proc type
moenchmeyer is offline   Reply With Quote