View Single Post
Old 12-01-03, 06:07 PM   #3
Sir_Brizz
Registered User
 
Join Date: Nov 2003
Location: la "mormona" cinturon
Posts: 19
Send a message via ICQ to Sir_Brizz Send a message via AIM to Sir_Brizz Send a message via Yahoo to Sir_Brizz
Default

thanks I was wondering if I was doing something wrong because I didn't have a XF86Config-4 file...

Anyways, to the blank screening. I am on SuSe 9.0 with the 2.6.0-test11 kernel. First of all, I can't seem to boot normally no matter what. If I just let it boot into Linux vanilla without any options, I get a black screen. I know it is doing stuff bc the hard drive light flickers. OK. So I go into Failsafe (with acpi, apic, apm etc all turned off) and I can get in...I still can't get into X with the nVidia drivers, I will either get a black screen with nothing on it and all I can do is reboot, or I get garbled ASCII characters all over the screen with the same result, all I can do is reboot. I tried installing from sources, with patches, etc etc etc and everytime I get the same result. I have tried setting NvAgp to every option under the sun and it has no effect. I am reduced to being able to access X from the nv driver only.

I have turned off FrameBuffer support in my kernel hoping that that was part of the problem, and no dice...I tried at one point turning off agpgart support in the kernel but that hammered my nic into disuse. I really have no idea what is going on...except that until I removed machine exception checking from the kernel I was getting bank error's every 5 seconds, which was very annoying. I hadn't had any trouble getting anything to work until I tried to get the graphics driver to work in any kernel since 2.4.21-144-athlon :-/

Any help or suggestions for me to try would be divine. I have started using the forcedeth driver for my NIC since this all started happening, and it works like a dream. I dunno if turning off agpgart in the kernel would make any difference though??
__________________
AMD Athlon XP 1700+ @ 2336mhz (JIUHB)
EPoX 8RDA+ nForce2
1gb PC2700 DDR
Visiontek GF4ti4600
SB Audigy 1 (w/ 1394)
Sir_Brizz is offline   Reply With Quote