View Single Post
Old 03-19-11, 05:46 AM   #10
vavoli
Registered User
 
Join Date: Mar 2011
Posts: 1
Default Re: KDE Desktop is frozen during cube rotation with direct rendering

Quote:
Originally Posted by danix View Post
I managed to get the cube to crash, but only when I set "OpenGL mode" to "Fallback" in the advanced tab. Since this option wasn't specifically called out in your problem description, can you clarify what OpenGL mode you're using? (The default was "Texture From Pixmap".) The crash I saw could be related, but it's hard to be sure...

Can you attach a debugger to kwin and post the backtrace when it crashes? It would be interesting to see if the call stack is similar in your case. (I'm assuming that kwin is crashing in your case too, but if it's a different bug, then that might not be the case...)
Hi, I think the problem is not completely opengl related. I managed to rotate cube without freezing in this manner:
1) open desktop effects tab advanced;
2) in opengl options uncheck "enable direct render" (I have italian language so I hope it's the right translation).
I'm on archlinux with nvidia driver 270.18 and kde 4.6.1
vavoli is offline   Reply With Quote