View Single Post
Old 03-31-11, 03:48 AM   #1
Ulukai
Registered User
 
Join Date: Jul 2010
Posts: 45
Default Color depth not respected in all games

My desktop runs in 24-bit mode (highest setting in nvidia-config) but I noticed that in games like Red Eclipse and Sauerbraten (Cube2), my color depth is not respected. The color depth option in those games is set to 24 or 32-bit but it always looks like 16-bit is being used. Colors in textures looks crappy and also background of menus look like ****, they become pixelated. When I open the background image in an image viewer, it is displayed correctly, but as soon as I start the game, it looks like crap. Other games like Xonotic, Doom 3, Quake 4, ... don't have this issue.

System:
64-bit Arch Linux fully updated (2.6.37.5 kernel + Nvidia 270.30)
AMD Phenom II X4 955
6GB DDR3 RAM
Geforce GTX 470

Also previous versions of the driver had this problem. I tried with enabling or diabling certain options in xorg.conf, but without success. 2D engine runs fine on 24-bit depth, but the Cube2 engine powered games suffer from this weird phenomenon. Other game engines work correctly. I was thinking about a problem with SDL (because that's what Cube2 uses), but Xonotic-SDL is not affected.

Any more tips or could this be a bug? If you need screenshots or config files to clarify this issue, don't hesitate to ask me. Thanks for all help.
Ulukai is offline   Reply With Quote