View Single Post
Old 03-31-11, 05:29 PM   #2
Ulukai
Registered User
 
Join Date: Jul 2010
Posts: 45
Default Re: Color depth not respected in all games

I would like to add that on my laptop with an Intel card and the same software versions installed (Arch Linux fully updated) the game runs correctly in 32 or 24-bit mode. That's why I think it is a problem with the driver or a configuration.

Here is my xorg.conf, generated with nvidia-xconfig.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NoLogo" "True"
Option "RenderAccel" "True"
Option "TripleBuffer" "True"
Option "BackingStore" "True"
Option "DamageEvents" "True"
Option "OnDemandVBlankInterrupts" "True"
Option "Coolbits" "5"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Any ideas?
Ulukai is offline   Reply With Quote