View Single Post
Old 04-06-11, 04:20 PM   #1
naib
Registered User
 
Join Date: Nov 2004
Posts: 8
Default nvidia-270.30, xorg-server-1.10.0.901 & resizing + ongoing issue

The 260.* drivers had issues with 3d app (or 2D apps that indirectly linked to libGL: eg gvim -> cairo -> libGL resulting in gvim issues...)

later 260.* version improved the situation BUT did not completely remove 3D app issues with these drivers.
Likewise the 270.* line is not immune to this.

I play HeroesOfNewerth a fair amount and the last drivers that were problem-free were the 256.* drivers
early 260.* I would crash a couple of times a game
later 260.* and 270.* I would crash every other game

UNLESS: I launch HoN in a new Xserver:
Code:
newx() { DISPLAY=:1.0; xinit $* -- :1; }; /opt/HoN/hon.sh
Then via ctrl-alt-F7,8 I can switch between desktop and HoN without crashing.


Prior to this I was able to track down the crashes occurred whenever there was some form of 2D:3D transition. Be it the initial load screen -> map or if there is some form of OSD popup (libnotify from say exaile, skype [the skype trigger was the one that made me really look into this and force some libnotify events])

example crashlog from hon.x86_64
Code:
Signal: Segmentation fault

Backtrace:
./hon-x86_64() [0x408884]
/lib64/libpthread.so.0(+0xf4d0) [0x7fd54dc2e4d0]
/usr/lib64/libnvidia-glcore.so.270.18(+0xec927a) [0x7fd52d73727a]
//usr/lib64/opengl/nvidia/lib/libGL.so.1(+0x733e2) [0x7fd52e9853e2]

Memory map:
00400000-0040d000 r-xp 00000000 08:03 13058180                           /opt/HoN/hon-x86_64
0060c000-0060d000 rwxp 0000c000 08:03 13058180                           /opt/HoN/hon-x86_64
0060d000-40131000 rwxp 00000000 00:00 0                                  [heap]
40133000-401aa000 rwxp 00000000 00:00 0
41ce2000-41ce4000 r-xs 00000000 00:11 162805                             /tmp/gl38xEiO (deleted)
41fed000-42064000 rwxp 00000000 00:00 0
7fd4f741d000-7fd4fef03000 rwxp 00000000 00:00 0
7fd4fef03000-7fd4ff425000 rwxp 00000000 00:00 0
7fd4ff625000-7fd4ff925000 rwxs 51e07000 00:0e 8412                       /dev/nvidia0
7fd4ff925000-7fd4ffb25000 rwxs 67532000 00:0e 8412                       /dev/nvidia0
7fd4ffc0b000-7fd500125000 rwxp 00000000 00:00 0
7fd500125000-7fd500a6b000 rwxp 00000000 00:00 0
7fd500a6b000-7fd50106b000 rwxp 00000000 00:00 0
7fd50106b000-7fd50171f000 rwxp 00000000 00:00 0
7fd50171f000-7fd501d41000 rwxp 00000000 00:00 0
7fd501d41000-7fd501f41000 rwxp 00000000 00:00 0
...
Again nvidia drivers and pthreads



Onto newer issues. Since running hon in a separate xsession (and thus no overlay from any OCD's occur) I have been running a composite desktop via xcompmgr for a bit more shiny to my openbox.
Problem is a nasty bug has occured with nvidia-270.30 + xorg-server-1.10...
If I go to resize a simple terminal the entire system locks up (and the display gets corrupted). I can just about ssh in BUT the system will not respond to system calls like shutdown et al.


Attached is the required nvidia bug report:
Attached Files
File Type: gz nvidia-bug-report.log.gz (46.3 KB, 53 views)
naib is offline   Reply With Quote