View Single Post
Old 04-09-11, 12:30 PM   #29
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: Linux drivers for GE Force 500M Series (GT 540M in particular)

I have no direct experience with Ubuntu, but basically you need the intel driver (the package name is xserver-xorg-video-intel). Also, I'm almost completely sure your kernel is too old. Someone who uses Ubuntu should tell you how to upgrade to 2.6.38. Then go here: http://linux-hybrid-graphics.blogspot.com/ and inform yourself how to deactivate the nvidia card so it won't drain your battery.

Edit: Actually, it's not just your kernel that's too old, Ubuntu's default intel driver is too, and possibly so is mesa. You see, Sandy Bridge was released after Ubuntu 10.10 was. You need version 2.14 of the intel driver, don't know about mesa. There's probably a ppa that has all the necessary stuff.
Gusar is offline   Reply With Quote