View Single Post
Old 04-26-11, 10:23 AM   #1
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Laptop, dual monitor, twinview: no easy way out

Hy guys, after searching, googling and trying several thigs I guess I need some help, even a link to some useful documentation (that I've not read ) will be most welcome.
Problem:
I'm using a HPElitebook 8440p with NVIDIA GPU NVS 3100M , nvidia drivers 270.41.03, X.Org X Server 1.10.1 (with queue patch to avoid lockups), gentoo 64bit platform.
I usually have two different monitors attached (different resolution) but often I have to disconnect one monitor and use the laptop with only his LCD or attach it to a different monitor.
Right now I'm using twinview option and all works fine, besides the fact that I'm unable, no matter what, to tell xorg to rescan and/or be aware of a monitor change, unless I restart xorg. As you can understand this is pretty cumbersome.
I don't require any auto detection when a monitor is detected or disconnected; I've tried to activate HP WMI to detect fn+f4 (monitor output), activated acpid and placed
Option "EnableACPIHotkeys" "true" but I'm unable to tell xorg to rescan or twinview to manage properly a monitor change situation. I could be enough to find a command or something else that could be scripted and activated by some key combination, but so far I've had no success.
right now my configuration is the following, that allows me to work fine (laptop LCD is the primary monitor, otherwise the toolbar management becomes a nightmare) once I have monitor connected at x startup.
I'll be glad to anyone able to give me some hints on how to sort this out, it is really annoyng. I know that this topic has been discussed a lot but I failed to find a solution, no matter how hard I tried.


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Option "Xinerama" "0"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
ModulePath "/usr/lib64/opengl/xorg-x11/extensions/"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "NVS 3100M"
Option "AllowDDCCI" "true"
Option "RegistryDwords" "EnableBrightnessControl=1"
Option "EnableACPIHotkeys" "true"
Option "DPMS" "FALSE"
EndSection


Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-3"
Option "metamodes" "CRT: nvidia-auto-select +1600+0, DFP: nvidia-auto-select +0+0"
Option "DPI" "96 x 96"
SubSection "Display"
Depth 24
EndSubSection
EndSection
cova is offline   Reply With Quote