View Single Post
Old 05-21-11, 03:44 PM   #1
maro
Registered User
 
Join Date: Feb 2004
Location: Holy Roman Empire
Posts: 64
Lightbulb patch for 96.43.19 on kernel 2.6.39

just for info, in case someone needs it, the following patch allows installation of the legacy driver on 2.6.39:
Code:
# Instructions for this patch:
#
# 1. cd into suitable work directory
# 2. sh /path/to/NVIDIA-Linux_x86-96.43.19-pkg0.run -x
# 2. cd NVIDIA-Linux_x86-96.43.19-pkg0
# 4. patch -p0 < /path/to/nvidia_96.43.19_for_kernel_2.6.39.patch
# 5. ./nvidia-installer (add your command line switches)
# 6. clean up if required
#
# Dr. Martin Rogge, 2011-05-21


--- usr/src/nv/nv-linux.h.orig	2010-10-28 04:23:04.000000000 +0200
+++ usr/src/nv/nv-linux.h	2011-05-21 08:58:35.714633248 +0200
@@ -80,7 +80,6 @@
 #if !defined(KERNEL_2_4)
 #include <linux/sched.h>            /* suser(), capable() replacement   */
 #include <linux/moduleparam.h>      /* module_param()                   */
-#include <linux/smp_lock.h>         /* kernel_locked                    */
 #include <asm/tlbflush.h>           /* flush_tlb(), flush_tlb_all()     */
 #include <asm/kmap_types.h>         /* page table entry lookup          */
 #endif
maro is offline   Reply With Quote