View Single Post
Old 05-27-11, 10:19 AM   #26
DarkOneX
Registered User
 
Join Date: Jul 2003
Location: Kansas
Posts: 327
Default Re: EVGA 570 WORST CARD EVER

My eVGA GTX 570 Superclocked started doing the same thing, not 2 months old even, bad artifacting and "your video driver has quit responding" black screen crap. That was a big part of the reason I built a completely new PC just a couple months ago, well that and I had my old one for 6 years so it was time, so it's frustrating as hell the new setup is doing the same crap! Sending it back, but it's free (I chose the $0 UPS ground option) but I didn't want to wait for weeks to get it back so I ordered the Gigabyte 570 3 fan version from Newegg for $344 - $30 rebate, then I'll just sell the one eVGA sends me back. Seems like every eVGA card I've bought in the past few years ends up doing this same thing, usually not after just buying it though! Hopefully the Gigabyte will be different....
__________________

Desktop - {i7-960 3.2Ghz} {Asus P6X58D-E} {24GB Corsair DDR3} {EVGA GTX670 FTW 2GB} {Intel 330 Series 180GB SSD} {(3X) WD Black 1TB HDDs} {Seagate 750GB HDD} {WD 4TB external} {WD 2TB external} {20X DVD-RW} {X-Fi} {Corsair HX850 PSU} {CM690 II case} {24" Dell U2410 LCD} {20" Dell 2007FP LCD} {Logitech G500} {Logitech G710+} {Windows 7 64bit} {CP1500PFCLCD UPS

Laptop 1 - {Lenovo Ideapad Y400} {i7-3630QM 2.4Ghz} {8GB DDR3} {GeForce GT750M 2GB} {1TB HDD + 16GB SSD} {14" Anti-Glare (1366x768)} {Windows 8 64bit

Laptop 2 - {HP DM4-3090se Beats Edition} {i5-2430M 2.4Ghz} {8GB DDR3} {Intel 3000 HD graphics} {500GB HDD} {14" LED Display (1366 x 768)} {Windows 8 64bit
DarkOneX is offline   Reply With Quote