View Single Post
Old 06-05-11, 05:00 AM   #1
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Inconsistency detected by ld.so: dl-close.c: 275.09

Some people (like me ) seems to be affected by the error message above, the full text being:

Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!

an easy way to reproduce it is (on gentoo systems)
:
kefk ~ # python -c 'import PyQt4.Qt'
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
kefk ~ # eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11
kefk ~ # eselect opengl set 2
Switching to xorg-x11 OpenGL interface... done
kefk ~ # python -c 'import PyQt4.Qt'
kefk ~ # eselect opengl set 1
Switching to nvidia OpenGL interface... done
kefk ~ # python -c 'import PyQt4.Qt'
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
kefk ~ #

bug report attached, driver version 275.09 - X86_64 - Gentoo - glibc 2.13-r2
gentoo bug report:
https://bugs.gentoo.org/show_bug.cgi?id=369993
Attached Files
File Type: gz nvidia-bug-report.log.gz (61.4 KB, 74 views)

Last edited by cova; 06-05-11 at 05:03 AM. Reason: Added some detail
cova is offline   Reply With Quote