View Single Post
Old 06-09-11, 01:55 PM   #1
MartinKG
Registered User
 
Join Date: Dec 2008
Location: Germany
Posts: 10
Default Slow vpdau with GeForce GT 520 (GF119)

Hi,

Mainboard Asus P8P67
Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
GeForce GT 520
Kernel: 2.6.38.8-31.fc15.x86_64
system: Fedora 15 x86_64
Nvidia driver: 260.19.21-2
xorg-x11-server: 1.10.2-1.fc15

I don't know why but when i run qvdpautest on my machine, the H264 DECODING (1920x1080):
only shows 4 frames/s compared to other users who have the same graphic card.

The same results with driver version 270.41.06, 270.41.19, 275.09, 275.09.04,

Code:
[root@fc15 tmp]# qvdpautest 
qvdpautest 0.5.1
Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
NVIDIA GPU GeForce GT 520 (GF119) at PCI:2:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  270.41.19  Mon May 16 23:51:36 PDT 2011

SURFACE GET BITS: 317.734 M/s
SURFACE PUT BITS: 342.547 M/s

MPEG DECODING (1920x1080): 184 frames/s
MPEG DECODING (1280x720): 410 frames/s
H264 DECODING (1920x1080): 4 frames/s
H264 DECODING (1280x720): 262 frames/s
VC1 DECODING (1440x1080): 83 frames/s
MPEG4 DECODING (1920x1080): 129 frames/s

MIXER WEAVE (1920x1080): 228 frames/s
MIXER BOB (1920x1080): 332 fields/s
MIXER TEMPORAL (1920x1080): 128 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 94 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 165 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 65 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 52 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 75 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 202 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 135 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 181 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 96 fields/s
when playing a H264 example video from the mplayer page, i see 59 fps

Code:
# mplayer -vo vdpau -vc ffh264vdpau xacti_hd2000_dogsample20090207_2a.mp4
Creating config file: /root/.mplayer/config
MPlayer SVN-r33251-4.6.0 (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing xacti_hd2000_dogsample20090207_2a.mp4.
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x1080  24bpp  59.940 fps  24182.4 kbps (2952.0 kbyte/s)
Clip info:
 major_brand: mp42
 minor_version: 1
 compatible_brands: mp42avc1
 creation_time: 2009-02-07 15:36:47
 comment: SANYO DIGITAL CAMERA HD2000
 comment-eng: SANYO DIGITAL CAMERA HD2000
Load subtitles in ./
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 127.7 kbit/8.31% (ratio: 15964->192000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration 
[VD_FFMPEG] XVMC-accelerated MPEG-2.
A:  14.6 V:  14.6 A-V: -0.068 ct: -0.023   0/  0  1% 98%  0.3% 676 0

MartinKG is online now Report Post   	Edit/Delete Message
Is this only a problem with Fedora or the NVidia driver ?
MartinKG is offline   Reply With Quote