View Single Post
Old 06-25-11, 10:03 AM   #25
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: 96.43.19 and XOrg 1.10.1

Quote:
Originally Posted by Huogo View Post
and how stupid are everyone here asking for basic support
Err, what?? Dude...

Quote:
Originally Posted by Huogo View Post
maybe for Christmas I'll be able to use Ubuntu 11.04.
Ok, so first you attack me for repeating myself, and then you go and ignore what is it actually that I'm saying.

Quote:
Originally Posted by Huogo View Post
But how do you explain that Nvidia users are the only ones affected ? Ati and Intel drivers aren't working just by chance with Xserver 1.10 !
Oh, they are very much affected. AMD doesn't provide a closed driver for legacy hardware at all. As for Intel, I could repeat what I already said, but that would just be more "congratulating myself".

Quote:
Originally Posted by Huogo View Post
And if Nvidia is not able to update the legacy driver, why don't they just opensourced it ?
One big reason would be the tons of third party code in there. Another would be the extensive review and clean-up of the code that would be necessary even if all the code was theirs. That'd be way too expensive, considering we're talking here about such old hardware.

Releasing documentation would likewise be a big undertaking, assembling the required docs in the first place, if it's even possible to get all of them. Then reviewing everything and clearing it for release. Not worth it for just the old hardware, it would only make sense if they had the plan to follow up and eventually catch up to the latest hardware, like AMD has done.

Quote:
Originally Posted by Huogo View Post
What is sure is that I won't buy again any Nvidia product.
If you have such an old card that requires the legacy 96xx driver, you haven't bought anything from them in a long time, so you weren't of much, if any, value to them anyway. Harsh and cold, but nevertheless correct.
Gusar is offline   Reply With Quote