View Single Post
Old 06-28-11, 12:07 AM   #3
DBabo
Registered User
 
Join Date: Dec 2010
Posts: 15
Default Re: mplayer -vc - no vdpau

Quote:
Originally Posted by zbiggy View Post
To use vdpau you have to have mplayer compiled with vdpau video output:
Your machine have mplayer compiled without vdpau output:
Code:
[az@server Downloads]$ mplayer -vo help | grep vdp
[az@server Downloads]$
Having just vdpau accelerated codecs is not enough. You have to have vdpau output to close the decoding chain by displaying decoded movie.

<skip>
Uhh, stupid me, thought that changing just one top line in the spec file of srpm will do the trick. Had to dig deeper.

zbiggy,
thank you very much for pointing to my error. I explicitly added vdpau to the call of the configure and now i enjoy my movies with ~20% CPU usage.

Full disclosure:
I run redhat clone (Scientific Linux 6) it's rpm based. I got mplayer src.rpm (mplayer-1.0-0.46.svn20100703.el6.src.rpm) from rpmforge.
To enable the vdpau i had to modify the spec file. Here is the diff:
Code:
diff -h mplayer.spec mplayer.spec00
19a20
> %define _without_dvdnav 1
144c145
< %{?_without_vdpau:BuildRequires: libvdpau-devel}
---
> %{!?_without_vdpau:BuildRequires: libvdpau-devel}
247d247
< %{?_without_vdpau:--enable-vdpau} \
hope it will be useful to someone.

Please mark as "resolved"
DBabo is offline   Reply With Quote