View Single Post
Old 07-07-11, 05:07 AM   #3
evena
Registered User
 
Join Date: Feb 2004
Posts: 14
Default Re: 275.09.07 crash glXWaitGL/logf

Still working on a test case,
Attached a log of the OpenGL calls, and a program to reproduce them,
The only problem is that it actually works as expected.

In the mean time I keep freezing Xorg, running at 100%,
with these call stacks:
[root@hol02 ~]# gdb -p 5903
GNU gdb (GDB) Red Hat Enterprise Linux (7.0.1-23.el5)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Attaching to process 5903
Reading symbols from /usr/bin/Xorg...(no debugging symbols found)...done.
Reading symbols from /lib64/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdl.so.2
Reading symbols from /usr/lib64/libXfont.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libXfont.so.1
Reading symbols from /usr/lib64/libXau.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libXau.so.6
Reading symbols from /usr/lib64/libfontenc.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libfontenc.so.1
Reading symbols from /usr/lib64/libXdmcp.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libXdmcp.so.6
Reading symbols from /lib64/libpam_misc.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libpam_misc.so.0
Reading symbols from /lib64/libpam.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libpam.so.0
Reading symbols from /lib64/libselinux.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libselinux.so.1
Reading symbols from /lib64/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/libm.so.6
Reading symbols from /lib64/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/libc.so.6
Reading symbols from /lib64/ld-linux-x86-64.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Reading symbols from /usr/lib64/libfreetype.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libfreetype.so.6
Reading symbols from /usr/lib64/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libz.so.1
Reading symbols from /lib64/libaudit.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libaudit.so.0
Reading symbols from /lib64/libsepol.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libsepol.so.1
Reading symbols from /usr/lib64/xorg/modules/fonts/libbitmap.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/fonts/libbitmap.so
Reading symbols from /usr/lib64/xorg/modules/libpcidata.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/libpcidata.so
Reading symbols from /usr/lib64/xorg/modules/extensions/libextmod.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/extensions/libextmod.so
Reading symbols from /usr/lib64/xorg/modules/extensions/libdbe.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/extensions/libdbe.so
Reading symbols from /usr/lib64/xorg/modules/extensions/libglx.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/extensions/libglx.so
Reading symbols from /usr/lib64/tls/libnvidia-tls.so.275.09.07...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/tls/libnvidia-tls.so.275.09.07
Reading symbols from /usr/lib64/libnvidia-glcore.so.275.09.07...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libnvidia-glcore.so.275.09.07
Reading symbols from /lib64/librt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/librt.so.1
Reading symbols from /lib64/libpthread.so.0...(no debugging symbols found)...done.
[Thread debugging using libthread_db enabled]
Loaded symbols for /lib64/libpthread.so.0
Reading symbols from /usr/lib64/xorg/modules/fonts/libfreetype.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/fonts/libfreetype.so
Reading symbols from /usr/lib64/xorg/modules/fonts/libtype1.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/fonts/libtype1.so
Reading symbols from /usr/lib64/xorg/modules/extensions/librecord.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/extensions/librecord.so
Reading symbols from /usr/lib64/xorg/modules/extensions/libdri.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/extensions/libdri.so
Reading symbols from /usr/lib64/xorg/modules/linux/libdrm.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/linux/libdrm.so
Reading symbols from /usr/lib64/xorg/modules/drivers/nvidia_drv.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/drivers/nvidia_drv.so
Reading symbols from /usr/lib64/xorg/modules/input/mouse_drv.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/input/mouse_drv.so
Reading symbols from /usr/lib64/xorg/modules/input/kbd_drv.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/input/kbd_drv.so
Reading symbols from /usr/lib64/xorg/modules/libfb.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/libfb.so
Reading symbols from /usr/lib64/xorg/modules/libwfb.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/libwfb.so
Reading symbols from /usr/lib64/xorg/modules/libramdac.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/xorg/modules/libramdac.so
Reading symbols from /lib64/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnss_files.so.2

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff5ebaf000
0x00002b2a53b322bd in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
(gdb) where
#0 0x00002b2a53b322bd in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#1 0x00002b2a53b33f00 in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#2 0x00002b2a53ba73a2 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#3 0x00002b2a53ccc632 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#4 0x00002b2a53ccb834 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#5 0x00002b2a53cd5eb6 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#6 0x00002b2a53ccb756 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#7 0x00002b2a53ccbd38 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#8 0x00000000004ddf10 in miPolyText8 ()
#9 0x000000000051d7ad in ?? ()
#10 0x000000000044e6e3 in doPolyText ()
#11 0x000000000044ebd4 in PolyText ()
#12 0x0000000000448ad9 in ProcPolyText ()
#13 0x000000000044b45a in Dispatch ()
#14 0x000000000043376e in main ()

And

Program received signal SIGINT, Interrupt.
0x00002b2a53b322c0 in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
(gdb) where
#0 0x00002b2a53b322c0 in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#1 0x00002b2a53b33f00 in sqrtf () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#2 0x00002b2a53ba73a2 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#3 0x00002b2a53ccc632 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#4 0x00002b2a53ccb834 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#5 0x00002b2a53cd5eb6 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#6 0x00002b2a53ccb756 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#7 0x00002b2a53ccbd38 in ?? () from /usr/lib64/xorg/modules/drivers/nvidia_drv.so
#8 0x00000000004ddf10 in miPolyText8 ()
#9 0x000000000051d7ad in ?? ()
#10 0x000000000044e6e3 in doPolyText ()
#11 0x000000000044ebd4 in PolyText ()
#12 0x0000000000448ad9 in ProcPolyText ()
#13 0x000000000044b45a in Dispatch ()
#14 0x000000000043376e in main ()

seems to loop at 22b0/22c0
evena is offline   Reply With Quote