View Single Post
Old 07-17-11, 04:03 PM   #9
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: Could not compile 'gcc-version-check.c' in my Debian box.

whaa, you compile your own kernel or it is unstable repository kernel compiled with gcc 4.6?
Because nVidia driver as a kernel module needs to be compiled with this same version of compiler as a kernel.

That's my kernel and I need to change GCC to 4.4 every time when I compile nVidia driver:
Code:
:~$ cat /proc/version
Linux version 2.6.39-2-amd64 (Debian 2.6.39-3) (ben@decadent.org.uk) (gcc version 4.4.6 (Debian 4.4.6-6) ) #1 SMP Tue Jul 5 02:51:22 UTC 2011
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote