View Single Post
Old 07-18-11, 09:32 AM   #18
Registered User
Join Date: Sep 2007
Posts: 22
Default Re: Could not compile 'gcc-version-check.c' in my Debian box.

That's a part stable, part testing and who knows what system, being that there's the squeeze kernel there and the rest kind of or wanting to being upgraded to newer than stable packages.

That kind of system nearly always becomes an impossible mess to deal with. The only package upgrades for Debian stable should be those from, squeeze-updates, (if desired), and the security repo.

And if running testing, then it looks like a kernel meta-package is not installed otherwise it would have 2.6.39 after aptitude full-upgrade from squeeze to wheezy.

Testing has had a broken nvidia (and fglrx until recently) since the 2.6.39 kernel upgrade due to the new multi-lib linking system that debian has chosen for it. That will be fixed sometime later today since the new nvidia packages have put in their time in sid and should come in today. What was happening is that when installing nvidia, the mesa support for 3D would be removed just as the above posts indicate. That's what's getting fixed in the new nvidia packages today.

The gcc version warning happens whenever the kernel was compiled with a different version of gcc than the nvidia driver installer uses. I have squeeze installed with the 2.6.38 kernel from squeeze-backports and the official nvidia installer (as well as previously the wheezy debian nvidia packages) have no gcc version mismatch problem at this time.

But even if they did, this was not the reason for the mesa support being removed. That was simply due to the linking problems in testing with the new multi-lib supporting kernel which, by the way, the OP isn't even using since he's still on 2.6.32 from squeeze! (See how confusing when mixing stable with anything else?)

A simple export CC=gcc_4.3whatever before installing using the official nvidia driver would eliminate the installer warning as long as the named gcc version was installed on the system. This isn't necessary at this time in stable even with the backported kernel (or with the stable kernel), but apparently is necessary if the user has full-upgraded to wheezy but is still using the squeeze kernel (a mixed system).

I purged the debian nvidia packages a couple of days ago and installed the just released download from nvidia in order to avoid needing to activate the wheezy sources and experiment with seeing whether the new linking system would allow the newer debian nvidia packages to install on stable with the old non-multi-lib supporting squeeze kernel. I just didn't want to keep using the debian packages I had when they would no longer be available except in my cache in case of a possible need to reinstall them. So I went with the nvidia download instead, putting an /etc/modprobe.d/disable-nouveau.conf in there as per the nvidia readme.

No gcc mis-match was reported on my system by the nvidia-installer as I don't mix stable up with the other distributions. But if the OP is really using testing, he should remove the stable source and upgrade the kernel to testing's kernel by installing the appropriate meta-package, like linux-image-2.6-amd64 or linux-image-2.6-686, etc, as well as the same for the linux-headers packages. Then a simple aptitude full-upgrade will keep him fully in testing in the future as well as ensuring the new nvidia packages will be installable without the package manager removing the mesa 3d stuff.
Epox EP-8KRAIPRO AthlonXP3200+ GeForce 6600GT 2x512MB PC3200 DDR-SDRAM SBLive 5.1 Platinum
dahveed3 is offline   Reply With Quote