View Single Post
Old 07-26-11, 01:48 PM   #1
Wadlax
Registered User
 
Wadlax's Avatar
 
Join Date: Feb 2006
Posts: 3
Default OpenGL performance - 2 cards Geforce GTX 470 , 4 Monitors, slow xinerama

Hello.

MB ASUS M4N98TD EVO ( NVIDIA nForce 980a SLI )
AMD Phenom(tm) II X6 1090T Processor
2 x Geforce GTX 470 (not SLI-connected) from MSI
4 x 1920x1080 monitors
16 gb ram
Nvidia drivers 275.19
Xorg server 1.10.2
Gentoo Linux x86_64 , KDE ,


OpenGL performance with some xorg setups

Code:
xorg.conf set with nvidia-settings

full xinerama -- 4 screens with xinerama
xinerama twinview -- xinerama connects 2 screens with twinview on 2 monitors
no xinerama twinview -- 2 separate screens with twinview on 2 monitors
no xinerama 38-42 fps -- 4 separate screens


Code:
  EVE-Online
  (wine-1.3.24 , i used same ingame scenes to benchmark)
full xinerama      __ 13-14 fps
xinerama, twinview    __ 27-30 fps
no xinerama, twinview __ 38-42 fps
no xinerama    __ 38-42 fps


  MegaGlassCube
  ( GLScene benchmark - rotates 5000 semi transparent cubes )
full xinerama     __ 20-22 fps
xinerama, twinview    __  27-28 fps
no xinerama, twinview  __ 32-33 fps
no xinerama     __ 31-32 fps


  GLXgears
  (small window, not resized = high fps)
full xinerama     __ 15400 fps
xinerama, twinview   __  17000 fps
no xinerama, twinview   __  18400 fps
no xinerama    __ 18400 fps

Questions :

Main - 1. Did i missed some hand-made settings? I used nvidia-settings to setup my xorg.conf file.
( maybe --enable-fast-xinerama )
Is there any chance to get full performance and Xinerama?


2. nvidia-settings: If i change "Digital Vibrance" on all monitors -- after reboot it is set to zero on monitors 1-3. Monitor 0 value is remembered.


nvidia-bug-report.log.gz -- sent to _linux-bugs at nvidia_com_ with link to current thread

Last edited by Wadlax; 07-26-11 at 01:53 PM. Reason: nvidia-bug-report.log
Wadlax is offline   Reply With Quote