View Single Post
Old 09-09-11, 10:18 AM   #1
migelito
Registered User
 
Join Date: Sep 2011
Posts: 3
Default direct rendering: No

Hello.
I have hp mini 311-1100 with ion on board, under slackware 13.1:
02:00.0 VGA compatible controller: nVidia Corporation ION VGA [GeForce 9400M] (rev b1)
Some time ago i install nvidia drivers, and all look good. But after i change some kernel version and now i cant get direct rendering, all time i get -
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
i try kernel version:
linux-2.6.38.7
linux-2.6.39.3
linux-2.6.39.4
linux-3.0
linux-3.0.4
linux-3.1-rc1
linux-3.1-rc4
and nvidia drivers version:
NVIDIA-Linux-x86-260.19.21.run
NVIDIA-Linux-x86-260.19.29.run
NVIDIA-Linux-x86-260.19.44.run
NVIDIA-Linux-x86-270.41.19.run
NVIDIA-Linux-x86-280.13.run
NVIDIA-Linux-x86-285.03.run
same result.
Tryed pci=nommconf, no effect.
For all kernel, all drivers compiled without error in process, but in log i find -
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are
missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it.
"; \
echo; \
/bin/false)

I can start X and no any trouble in use, but no direct rendering.
I try all solution what i find in internet - no result. All look good, but no work.
glxinfo | grep version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 2.1.2 NVIDIA 285.03
OpenGL shading language version string: (null)

If any one know whats happening, plz, let me know.

In attache: nvidia-installer.log, LIBGL_DEBUG=verbose glxinfo, xorg.conf
Attached Files
File Type: txt glxinfo.txt (25.6 KB, 55 views)
File Type: txt nvidia-installer.log.txt (67.7 KB, 54 views)
File Type: txt xorg.conf.txt (2.8 KB, 59 views)
migelito is offline   Reply With Quote